Bug 254721 - .rpmnew file spam
.rpmnew file spam
Status: CLOSED DUPLICATE of bug 128622
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
7
All All
medium Severity low
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-26 01:22 EDT by D. Wagner
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-26 14:29:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description D. Wagner 2007-08-26 01:22:05 EDT
Description of problem:
yum/rpm leave around dozens of pointless .rpmnew files: X.rpmnew is exactly
identical to X, so why bother to create X.rpmnew too? 

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. Install FC6 from DVD.  yum upgrade.
2. Upgrade to Fedora 7 using DVD.  yum upgrade.
3. updatedb.  locate .rpmnew.
  
Actual results:
There are dozens of pointless .rpmnew files in my filesystem.

Expected results:
rpm (or the rpm spec files) should not have created a .rpmnew / .rpmorig /
.rpmsave file if foo.rpmnew is exactly identical to foo.  Just leave foo in
place and don't bother creating an identical .rpmnew.

In general, rpm ought to be much better at allowing upgrading.  I had to do all
sorts of cleanup by hand, just for upgrading a clean FC6 -> F7 install.  That's
not reasonable to expect most users to do that.  Is it just me, or did this get
worse than it used to be?

Additional info:

P.S. The Redhat bugzilla makes it annoying to submit a bug.  First the "Guided"
mode submission doesn't work at all (the selection box to let me select a
component doesn't work, and it doesn't tell me until after I've gotten to the
end and try to submit that it's going to refuse to accept a bug from me). 
Second it forces me to submit the bug associated with some package -- even
though this is a cross-cutting issue that is associated with the entire
distribution rather than with a bug in a particular program.
Comment 1 Panu Matilainen 2007-08-26 04:42:22 EDT
Is this on x86_64? Sounds a lot like dupe of #128622 which has already been
addressed, update just hasn't made it to official updates of either FC6 nor F7 yet.
Comment 2 D. Wagner 2007-08-26 14:29:58 EDT
Yes, this is on x86_64.  Sorry about the duplicate.  Great to hear about the fix!

*** This bug has been marked as a duplicate of 128622 ***

Note You need to log in before you can comment on or make changes to this bug.