Bug 25473 - fs devices break on upgrade
Summary: fs devices break on upgrade
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Aaron Brown
URL:
Whiteboard: Florence RC-1
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-01 13:46 UTC by Tim Waugh
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-02 12:47:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here's the kdelnk file that no longer works (908 bytes, text/plain)
2001-02-01 13:47 UTC, Tim Waugh
no flags Details
Newly-created file that does work (138 bytes, text/plain)
2001-02-01 13:51 UTC, Tim Waugh
no flags Details
desktopconv result (878 bytes, text/plain)
2001-02-01 20:49 UTC, Tim Waugh
no flags Details

Description Tim Waugh 2001-02-01 13:46:32 UTC
On upgrade from Guinness, my ZIP icon has broken.

I have /dev/sda4 (the ZIP device) in console.perms, and have checked that
it is owned by the console user, and that 'mount /mnt/zip' works fine. 
Here's the fstab line:

/dev/sda4 /mnt/zip auto noauto,owner 0 0

Comment 1 Tim Waugh 2001-02-01 13:47:21 UTC
Created attachment 8639 [details]
Here's the kdelnk file that no longer works

Comment 2 Tim Waugh 2001-02-01 13:49:41 UTC
Here's the failure mode:

Konqueror window opens with URL
http://navigation.realnames.com/resolver.dll?action=navigation&realname=file%3A&charset=iso-8859-1&providerid=180&fallbackuri=http%3A//www.google.com/search%3Fq%3D%5C1

Modal dialog window opens with:

Unsupported action
listDir


Comment 3 Tim Waugh 2001-02-01 13:50:14 UTC
When creating a new icon, it works fine.  Old Desktop files should be upgraded,
IMHO.

Comment 4 Tim Waugh 2001-02-01 13:51:39 UTC
Created attachment 8640 [details]
Newly-created file that does work

Comment 5 Bernhard Rosenkraenzer 2001-02-01 19:49:33 UTC
Does running desktopconv fix this for you?



Comment 6 Glen Foster 2001-02-01 19:59:28 UTC
This defect is considered MUST-FIX for Florence Release-Candidate #1

Comment 7 Tim Waugh 2001-02-01 20:48:39 UTC
No, desktopconv made things much worse.  I replaced my newly made Zip file in
/home/tim/Desktop with the Zip.kdelnk that I attached to this bug, and ran
desktopconv from my home directory.  I ended up with a Desktop subdirectory
within my existing Desktop subdirectory, and so only one icon on my Desktop.

After removing one level of directories, I am left with a Desktop/Zip.  It
doesn't work, with similar symptoms as before the change.  I'll attach it.

Comment 8 Tim Waugh 2001-02-01 20:49:16 UTC
Created attachment 8659 [details]
desktopconv result

Comment 9 Bernhard Rosenkraenzer 2001-02-02 12:36:16 UTC
desktopconv converts KDE 1.x-ish config files to 2.x - running it after having 
changed config files to 2.x can't work.

Also, your KDE 1.x config is odd (no mountpoint listed). Are you sure this 
ever worked? Is /dev/sda4 listed in fstab?

Comment 10 Tim Waugh 2001-02-02 12:39:32 UTC
Why doesn't it spot that and just stop then, rather than f**king up the Desktop
subdir?

Yes, of course I'm sure this worked.  '/mnt/zip' shows up in the properties
dialog; presumably it gets that info from my /etc/fstab.

Can you reproduce this or not?

Comment 11 Bernhard Rosenkraenzer 2001-02-02 12:45:14 UTC
Yes, but since I don't have a ZIP drive, I couldn't tell for sure whether or 
not the original file worked.
The "Mountpoint=" line *is* odd.

I'll fix up desktopconv now.

Comment 12 Tim Waugh 2001-02-02 12:47:21 UTC
I don't think this is Zip-drive specific; a spare partition (or even a loopback
mount) might trigger it.

Comment 13 Bernhard Rosenkraenzer 2001-02-02 18:19:13 UTC
This is fixed in 2.0.20010201-2.
I've rewritten desktopconv to take care of these things (and it won't break 
existing KDE 2.x configs anymore).

Comment 14 Tim Waugh 2001-02-02 22:35:07 UTC
For the record, I was able to reproduce this on a machine with a VFAT partition
rather than a ZIP drive.

After running desktopconv (no upgrades from fisher), this time I got 'The
desktop entry file ... has no Type=... entry' when clicking on the icon.


Note You need to log in before you can comment on or make changes to this bug.