Bug 254741 - oocalc nearly unusable due to fault/assert crashes
oocalc nearly unusable due to fault/assert crashes
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
8
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-26 01:46 EDT by Michael McLagan
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-16 04:54:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error dump from oocalc 2> oocalc.XXX (8.96 KB, text/plain)
2007-08-26 01:46 EDT, Michael McLagan
no flags Details
Another error dump (9.48 KB, text/plain)
2007-08-26 01:51 EDT, Michael McLagan
no flags Details

  None (edit)
Description Michael McLagan 2007-08-26 01:46:29 EDT
Description of problem:

While trying to build a simple spreadsheet, the program crashes so often it is
nearly impossible to accomplish anything.  Saving after each change is the only
way to make progress, darn slow progress.  

Version-Release number of selected component (if applicable):

openoffice.org-calc-2.2.1-18.6.fc8

How reproducible:

Seems pretty repeatable.  Set horizontal borders around the whole sheet, then
try to set left side border on a column.

Steps to Reproduce:
1.  Open program
2. Recover from previous crash
3. Select column, right click to "Format cells", "Border" tab, left margin, "Ok"
4. Move two columns right and try again.  It's crashing almost 100% of the time
here.
  
Actual results:

Software spits out error messages and disappears from desktop.

Expected results:

I can set the borders on another column?

Additional info:

Running KDE 3.5 from F7.  I only got calc for F8 when the F7 one failed so much,
otherwise the system is F7.
Comment 1 Michael McLagan 2007-08-26 01:46:29 EDT
Created attachment 172801 [details]
Error dump from oocalc 2> oocalc.XXX
Comment 2 Michael McLagan 2007-08-26 01:51:25 EDT
Created attachment 172821 [details]
Another error dump
Comment 3 Michael McLagan 2007-08-26 01:54:30 EDT
Most recently, this is all it is spitting out:

[mmclagan@titan ~]$ oocalc &
X-Error: BadAlloc (insufficient resources for operation)
        Major opcode: 53 (X_CreatePixmap)
        Resource ID:  0x6001435
        Serial No:    61955 (61955)

Comment 4 Michael McLagan 2007-08-26 02:05:02 EDT
The most recent attempt produced:

[mmclagan@titan ~]$ oocalc                         
X Error: BadWindow (invalid Window parameter) 3
  Major opcode:  2
  Minor opcode:  0
  Resource id:  0x16000a0
X Error: BadWindow (invalid Window parameter) 3
  Major opcode:  2
  Minor opcode:  0
  Resource id:  0x16000b1
X-Error: BadWindow (invalid Window parameter)
        Major opcode: 2 (X_ChangeWindowAttributes)
        Resource ID:  0x16000b1
        Serial No:    362 (362)
X-Error: BadWindow (invalid Window parameter)
        Major opcode: 18 (X_ChangeProperty)
        Resource ID:  0x16000b1
        Serial No:    363 (363)
X-Error: BadWindow (invalid Window parameter)
        Major opcode: 25 (X_SendEvent)
        Resource ID:  0x16000b1
        Serial No:    364 (364)
X-Error: BadWindow (invalid Window parameter)
        Major opcode: 2 (X_ChangeWindowAttributes)
        Resource ID:  0x16000b1
        Serial No:    366 (366)
X-Error: BadWindow (invalid Window parameter)
        Major opcode: 18 (X_ChangeProperty)
        Resource ID:  0x16000b1
        Serial No:    367 (367)
X-Error: BadWindow (invalid Window parameter)
        Major opcode: 25 (X_SendEvent)
        Resource ID:  0x16000b1
        Serial No:    368 (368)
X-Error: BadWindow (invalid Window parameter)
        Major opcode: 2 (X_ChangeWindowAttributes)
        Resource ID:  0x16000b1
        Serial No:    370 (370)
X-Error: BadWindow (invalid Window parameter)
        Major opcode: 18 (X_ChangeProperty)
        Resource ID:  0x16000b1
        Serial No:    371 (371)
X-Error: BadWindow (invalid Window parameter)
        Major opcode: 25 (X_SendEvent)
        Resource ID:  0x16000b1
        Serial No:    372 (372)
X-Error: BadWindow (invalid Window parameter)
        Major opcode: 2 (X_ChangeWindowAttributes)
        Resource ID:  0x16000b1
        Serial No:    374 (374)
X-Error: BadWindow (invalid Window parameter)
        Major opcode: 18 (X_ChangeProperty)
        Resource ID:  0x16000b1
        Serial No:    375 (375)
X-Error: BadWindow (invalid Window parameter)
        Major opcode: 25 (X_SendEvent)
        Resource ID:  0x16000b1
        Serial No:    376 (376)
X-Error: BadWindow (invalid Window parameter)
        Major opcode: 2 (X_ChangeWindowAttributes)
        Resource ID:  0x16000b1
        Serial No:    378 (378)
X-Error: BadWindow (invalid Window parameter)
        Major opcode: 18 (X_ChangeProperty)
        Resource ID:  0x16000b1
        Serial No:    379 (379)
X-Error: BadWindow (invalid Window parameter)
        Major opcode: 25 (X_SendEvent)
        Resource ID:  0x16000b1
        Serial No:    380 (380)
X-Error: BadWindow (invalid Window parameter)
        Major opcode: 2 (X_ChangeWindowAttributes)
        Resource ID:  0x16000b1
        Serial No:    382 (382)
X-Error: BadWindow (invalid Window parameter)
        Major opcode: 18 (X_ChangeProperty)
        Resource ID:  0x16000b1
        Serial No:    383 (383)
X-Error: BadWindow (invalid Window parameter)
        Major opcode: 25 (X_SendEvent)
        Resource ID:  0x16000b1
        Serial No:    384 (384)
X-Error: BadWindow (invalid Window parameter)
        Major opcode: 18 (X_ChangeProperty)
        Resource ID:  0x16000b1
        Serial No:    385 (385)
X-Error: BadWindow (invalid Window parameter)
        Major opcode: 18 (X_ChangeProperty)
        Resource ID:  0x16000b1
        Serial No:    386 (386)
X-Error: BadAlloc (insufficient resources for operation)
        Major opcode: 53 (X_CreatePixmap)
        Resource ID:  0x60031d3
        Serial No:    150231 (150231)
Comment 5 Caolan McNamara 2007-08-26 13:39:00 EDT
Looks like there is some cut and paste problem going on here, is "klipper"
running, perhaps if you disable klipper temporarily that might work around the
problem, can you try that to see if we can isolate the problem to continuous
klipper copy efforts.
Comment 6 Caolan McNamara 2007-10-04 04:10:39 EDT
KDE or some other environment ?

Note You need to log in before you can comment on or make changes to this bug.