Bug 2548 - sndconfig crashes attempting to play MIDI sound
sndconfig crashes attempting to play MIDI sound
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: sndconfig (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-04 16:09 EDT by awaite
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-23 17:23:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description awaite 1999-05-04 16:09:51 EDT
when sndconfig reports that it is trying to play a MIDI
sound to test the config, it gives the error:

modprobe error
the following error occurred while trying to run the
modprobe program:


and it's blank. it then drops down into manual config, but
even then it loops and crashes at the same point.
I'm using redhat 5.9 with the sndconfig package upgraded to
6.0's version (0.33-1). I am running it as root, and
modprobe is in my path.

my soundcard is an AWE-64 Value, which is detected properly,
and I can hear Linus' voice.
Comment 1 Bill Nottingham 1999-05-05 10:26:59 EDT
What happens if you do 'modprobe awe_wave' from the command line?

------- Email Received From  Adam Waite <awaite@ammo.jic.com> 05/05/99 19:02 -------
Comment 2 Bill Nottingham 1999-05-10 12:21:59 EDT
Is there an awe_wave module anywhere under /lib/modules?
Comment 3 Joe Acosta 1999-05-21 10:30:59 EDT
this may seem obvious but did you configure the lowlevel drivers and
enable the AWE in the lowlovel drivers? Is there a
/lib/modules/2.2.x/misc/awe_wave  modules?  I have an AWE64 and it
works on my system  sndconfig --noprobe
Comment 4 Bill Nottingham 1999-06-23 17:23:59 EDT
closed due to lack of input.
Comment 5 kumar1 1999-08-22 01:41:59 EDT
I have a solution to this problem. To get the midi working, read up
the kernel documentation on the AWE32 sound card. It states that you
need to manually edit the /etc/isapnp.conf file to add 3 io ports to
the wavetable device. Once you do this everything works great.

Note You need to log in before you can comment on or make changes to this bug.