Bug 25481 - The built in echo-udp and daytime-udp servers don't work
The built in echo-udp and daytime-udp servers don't work
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xinetd (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-01 10:38 EST by David Lawrence
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-01 15:06:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
python script to exhibit xinetd problem (962 bytes, text/plain)
2001-02-01 12:18 EST, Derek Tattersall
no flags Details

  None (edit)
Description Derek Tattersall 2001-02-01 10:38:12 EST
I have python scripts that open a udp socket to the echo and daytime
internal xinetd servers, and do 10 replications of the send/redcieve udp
pair.  This works as expected with xinetd-2.1.8.9pre11-1 from RHL 7.0, but
fails with xinetd-2.1.8.9pre14-2 or -3 from RHL 7.1
beta 3.

The failure seems to be going into an eternal wait for a response.
Comment 1 Trond Eivind Glomsrxd 2001-02-01 11:28:06 EST
Could you attach that script?
Comment 2 Derek Tattersall 2001-02-01 12:18:09 EST
Created attachment 8646 [details]
python script to exhibit xinetd problem
Comment 3 Glen Foster 2001-02-01 14:59:32 EST
This defect is considered MUST-FIX for Florence Release-Candidate #1
Comment 4 Glen Foster 2001-02-01 15:06:13 EST
After more investigation, this defect is no longer a MUST-FIX for the Florence
release.
Comment 5 Trond Eivind Glomsrxd 2001-02-27 01:09:53 EST
Problem removed in xinetd-2.1.8.9pre14-6 - xinetd really wants to use same
servicename for the tcp and udp versions. This doesn't match well with our
current tools. Also, I've yet to see the UDP servers being used while the TCP
versions are somewhat used.

Note You need to log in before you can comment on or make changes to this bug.