Bug 25486 - wu-ftp still install when don't needed
wu-ftp still install when don't needed
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-01 11:10 EST by Levente Farkas
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-01 13:41:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2001-02-01 11:10:14 EST
wu-ftpd still installed when there already an installed proftpd on the 
system.
Comment 1 Bernhard Rosenkraenzer 2001-02-01 11:12:27 EST
Not a bug. If you ask the installer to install wu-ftpd (which you do
by selecting to install the networking packages), it should do just
that.
Comment 2 Levente Farkas 2001-02-01 11:35:41 EST
when I ask the installer to UPGRADE to 7.0 from 6.2 and do NOT choose or
change any package than I assume it is just fresh (ie. rpm -F) and the
required packages are installed.
and that's not true, since wu-ftpd was not installed and after the upgrade
it's installed.
Comment 3 Bernhard Rosenkraenzer 2001-02-01 11:42:22 EST
That's what it does... You probably didn't deinstall your old
wu-ftpd package using rpm. The installer uses the rpm database to
figure out which packages you have installed.

Reassigning to anaconda (the installer) so they can check for
sure whether or not there's a problem.
Comment 4 Matt Wilson 2001-04-03 19:02:43 EDT
does proftpd have a "Conflicts: wu-ftpd" in the package?  If not, we try to
offer wu-ftpd as a surrogate parent for /usr/sbin/in.ftpd.  You would need to
deselect wu-ftpd in "customize pacakges to upgrade" if this explicit Conflicts:
is missing from the package.

Note You need to log in before you can comment on or make changes to this bug.