Bug 25491 - r128.o module does not produce 3d acceleration
Summary: r128.o module does not produce 3d acceleration
Status: CLOSED DUPLICATE of bug 21545
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: Brock Organ
URL:
Whiteboard: Florence Gold
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-01 16:25 UTC by Need Real Name
Modified: 2007-04-18 16:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-02 00:39:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-02-01 16:25:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.0-0.99.11 i686)


The r128.o module will load and claim that it is in use (via lsmod) but
OpenGL programs do not take advantage of it. 

Reproducible: Always
Steps to Reproduce:
1.Run Chromium
2.
3.
	

Actual Results:  It made the computer crawl

Expected Results:  It should have been fast

Video Card is ATI Rage Fury 128

Comment 1 Arjan van de Ven 2001-02-01 16:37:39 UTC
It's up to the X server to do/use the actual acceleration. Reassigning.

Comment 2 Jeremy Katz 2001-02-01 19:48:15 UTC
A couple of things to look at:
* Ensure that the glx and dri modules are being loaded from the module section
of /etc/X11/XF86Config-4
* Check the permissions on /dev/dri/card0 to make sure that you have read and
write access to the device
* Run glxinfo to see if it shows that direct rendering is enabled

Comment 3 Glen Foster 2001-02-01 20:01:26 UTC
We (Red Hat) should really try to fix this before the next release.

Comment 4 Need Real Name 2001-02-01 20:11:31 UTC
The /etc/X11/XF86Config-4 file was missing a line. 

Section "DRI"
             Mode 0666  <-- This
End Section

Only root had 3D acceleration and regular users did not. I think it would be
nice if all users had permission to DRI by default.

Comment 5 Bill Nottingham 2001-02-02 00:39:32 UTC
That in the past has been bad (all users could lock the machine).

Currently to do this you must

a) log in as root
 or
b) log in via xdm/kdm/etc.

Comment 6 Bill Nottingham 2001-02-02 00:42:39 UTC

*** This bug has been marked as a duplicate of 21545 ***


Note You need to log in before you can comment on or make changes to this bug.