Bug 255021 - ALi onboard soundcard not autodetected
ALi onboard soundcard not autodetected
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
7
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-26 10:28 EDT by Al Dunstan
Modified: 2008-02-22 05:44 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-22 05:44:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
combined scsrun.log and scsconfig.log (47.65 KB, text/plain)
2007-08-26 10:28 EDT, Al Dunstan
no flags Details

  None (edit)
Description Al Dunstan 2007-08-26 10:28:54 EDT
Description of problem:
  After upgrading from FC5 to Fedora 7 the 'soundcard' stopped working.  
Running system-config-soundcard & asking it to play the sound test results in 
silence; the error dialog box says "Automatic detection of the sound card did 
not work".  I've got all the sliders turned up to 100 in kmixer, I've tried 
the speaker in all the likely audio jacks.  I accidentally plugged it into the 
microphone jack - I heard a bit of static, so the speakers _are_ able to make 
some sound.  And I do hear a little bit of static when I shut things down.


Version-Release number of selected component (if applicable):
system-config-soundcard-2.0.6-6.fc7

How reproducible:
Try to play a sound.  /usr/bin/play, mplayer, kplayer, etc.

Actual results:
The Sounds of Silence.

Expected results:
Something besides Simon & Garfunkel.

Additional info:
It worked in FC5.

I've attached the scsrun.log and scsconfig.log, all in one file.
Comment 1 Al Dunstan 2007-08-26 10:28:54 EDT
Created attachment 172981 [details]
combined scsrun.log and scsconfig.log
Comment 2 Martin Stransky 2007-09-10 07:24:27 EDT
ACPI: PCI Interrupt 0000:00:1d.0[C] -> GSI 21 (level, low) -> IRQ 21
hda_codec: Unknown model for ALC882, trying auto-probe from BIOS...

Looks like a problem in kernel/drivers...

aplay: main:545: audio open error: Device or resource busy

It looks like your sound card is used by another application (or is nonfunctional).

Anyway, you have quite old sound drivers (1.0.14rc1) please try to update
kernel/alsa-lib/alsa-utils packages.
Comment 3 Al Dunstan 2007-09-11 01:27:21 EDT
I'd updated everything (yum update) as soon as I did the FC5-to-Fedora7 
upgrade, and have been keeping it up-to-date since.  Current versions of Alsa 
& kernel are:

% rpm -qa '*alsa*' '*kernel*' | sort
alsa-lib-1.0.14-3.fc7
alsa-lib-1.0.14-3.fc7
alsa-lib-devel-1.0.14-3.fc7
alsa-oss-1.0.12-4.fc7
alsa-oss-libs-1.0.12-4.fc7
alsa-utils-1.0.14-1.fc7
kernel-2.6.22.1-41.fc7
kernel-2.6.22.4-65.fc7
kernel-devel-2.6.22.1-41.fc7
kernel-devel-2.6.22.4-65.fc7
kernel-headers-2.6.22.4-65.fc7

uname -a reports:
Linux bob2 2.6.22.4-65.fc7 #1 SMP Tue Aug 21 21:50:50 EDT 2007 x86_64 x86_64 
x86_64 GNU/Linux

I haven't looked anywhere for more up-to-date versions of Alsa (I'll have to 
do that tomorrow - it's getting late).

The sound card worked under FC5.

The 'sound card' is on the motherboard (an Abit AT8 32X, with an AMD 4400+).

Thanks!
Comment 4 Martin Stransky 2008-02-22 05:44:05 EST
Unfortunately s-c-s was removed from F9 and it's not going to be developed.
Closing as wontfix.

If you have any hardware support issue, please file it against kernel.

Note You need to log in before you can comment on or make changes to this bug.