Bug 25504 - Sound subsystem locks on Yamaha Corporation YMF-744B after suspend
Sound subsystem locks on Yamaha Corporation YMF-744B after suspend
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
Florence Gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-01 13:09 EST by Donald Harper
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-01 14:44:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Donald Harper 2001-02-01 13:09:51 EST
After manually modprobe -a ymfpci, sound works great until I hardware
suspends.  Then, it locks the sound subsystem on resume.  xmms process goes
into a blocked waiting for IO state, and I have to reboot to clear it up.
Comment 1 Glen Foster 2001-02-01 14:44:26 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 2 Bernhard Rosenkraenzer 2001-02-08 13:19:09 EST
Set RESTORESOUND and RESTORESOUNDPROGS to yes in /etc/sysconfig/apmd.
Also, add your sound module to the SOUNDMODULES list.

/etc/sysconfig/apmd is full of possible workarounds for broken
hardware and BIOSes (along with comments on when/how the workarounds
need to be activated).
Comment 3 Donald Harper 2001-02-08 13:31:01 EST
Cool..thanks...I will test this out as soon as I finish a compile...


Note You need to log in before you can comment on or make changes to this bug.