Bug 25506 - installer X configurator fails to produce working X setup
installer X configurator fails to produce working X setup
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Florence Gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-01 13:18 EST by Richard Hyde
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-17 15:23:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Hyde 2001-02-01 13:18:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16-22smp i686)


The installer fails to produce a X setup that will test properly on my IBM
A21m with Rage Mobility (as detected).  Attempted all other Rage Mobility
variants.  There is no X server output on any of the VTs so I can't really
say what it is bombing out on.

Reproducible: Always
Steps to Reproduce:
1. starting installer	
2. test video config button	
3. change video setup
4. wash rinse repeat
Comment 1 Michael Fulbright 2001-02-01 13:36:16 EST
Assigning to a developer.
Comment 2 Glen Foster 2001-02-01 14:45:27 EST
We (Red Hat) should really try to fix this before the next release.
Comment 3 Brent Fox 2001-02-01 16:54:36 EST
The X output is in a file called /tmp/X.log.  Can you send me the contents of
this file?
Comment 4 Richard Hyde 2001-02-08 00:47:08 EST
/tmp/X-test.log:

(relevant lines)
(II) ATI(0): Using digital flap panel interface
...
Default modes deleted, [hsync, vrefresh] out of range
..
>1024x768 default modes deleted (exeeds panel dimensions)
...
Built-in mode "Native panel mode" deleted (vrefresh out of range)
(WW) ATI(0): Mode pool is empty
...

Fatal server error:
no screens found
Comment 5 Richard Hyde 2001-02-08 00:54:50 EST
When removed from the port replicator the system installs without trouble.  

Port replicator has two ports, standard VGA and DVI.  It looks like the
installer sees the DVI and doesn't bother with the VGA port.  Even when
selecting the [crt] monitor manually the X-test.log tells me that X is trying to
use the DVI interface.  Looks as if the installer prober is doing the same thing
as the probed monitor is coming up as "flat panel 1024x768".
Comment 6 Brent Fox 2001-02-09 04:44:32 EST
It looks like kudzu needs more intelligent probing routines.  There isn't time
to fix this for the current release, but it's a nice idea.  I'll add this to our
feature request list and defer it to a future release.  Thanks for your report.
Comment 7 Richard Hyde 2001-02-09 13:46:21 EST
I hope this goes in the release notes, it really should.  Sounds like (from
another bugzilla bug) that someone is having a similar port replicator problem
with their Dell.
Comment 8 Need Real Name 2001-05-02 21:43:51 EDT
I see this same problem on Dell Latitude CPx laptops (same video chipset I
believe).  It would be nice if the X _driver_ handled this vs. kudzu as that's
how it really should happen.  There is an X option for something like
"external_crt" or something like that... this allows the external monitor to
work, but otherwise, it will not work with the monitor.

I would really love to see XFree86 (I know this isn't YOU guys directly) be able
to handle hardware changes better for laptops (I use the build-in pointer and
switch to scrollmouse (well, really vie versa, which screws things up).  Maybe
an option should be used by XFree86 to try one config then another or
something.... anyway, don't know if anyone will read this, so I'll stop now ;)
Comment 9 Brent Fox 2001-05-03 11:40:46 EDT
I read it, and I agree.  :)  There's a lot of things about laptops that I wish
Linux handled better...(power management, hibernation, etc.)

Note You need to log in before you can comment on or make changes to this bug.