Bug 25512 - [patch] Pine does not decrypt messages.
Summary: [patch] Pine does not decrypt messages.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pine   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard: Florence Gold
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-01 19:31 UTC by Sue Taylor
Modified: 2007-04-18 16:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-03 11:32:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pine-4.32-quote.patch (310 bytes, patch)
2001-02-02 12:55 UTC, Tim Waugh
no flags Details | Diff

Description Sue Taylor 2001-02-01 19:31:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.0-0.99.11 i586)


Messages that are sent encrypted (using Pine) do not get decrypted at the
other end (using Pine).

Reproducible: Always
Steps to Reproduce:
1.Send encrypted message to self using Pine.
2.Read message.  Note that it is encrypted and you can not read it.
3.
	

Actual Results:  An encrypted message is shown.

Expected Results:  It should ask for your password and decrypt the message.

Comment 1 Tim Waugh 2001-02-01 19:35:42 UTC
Verified.  Last worked in pine-4.31-2.

Comment 2 Glen Foster 2001-02-01 19:45:23 UTC
We (Red Hat) should really try to fix this before the next release.

Comment 3 Tim Waugh 2001-02-02 12:55:05 UTC
Created attachment 8722 [details]
pine-4.32-quote.patch

Comment 4 Tim Waugh 2001-02-02 12:56:15 UTC
I think the above patch is right.  get_pair _used_ to strip quotes from labels,
at least.

Comment 5 chappa 2001-02-02 23:32:28 UTC
This is a known problem in pine4.32 and it was fixed in the release of Pine4.33
yesterday. The fix is different from the proposed here and I would recommend to
use the pine team solution. The funxtion get_pair is called from several
different places and I'm not quite sure this solution will fix all calls. In any
case 4.33 is out and fixes the bug

Comment 6 Tim Waugh 2001-02-03 11:31:58 UTC
(Confirmed; 4.33 works for me.)


Note You need to log in before you can comment on or make changes to this bug.