Bug 25516 - Installer doesnt turn on swap early enough on low mem machines
Summary: Installer doesnt turn on swap early enough on low mem machines
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard: Florence RC-1
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-01 19:56 UTC by Brent Nordquist
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-27 02:31:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brent Nordquist 2001-02-01 19:56:45 UTC
During a text FTP custom install of Fisher beta-3, the following groups are
selected.  The dialog "Dependency Check" is then presented, and anaconda
exits (no traceback option):  "install exited abnormally -- received signal
15".  Reproducible.

Printer Support
X Window System
GNOME
Mail/WWW/News Tools
DOS/Windows Connectivity
Graphics Manipulation
Games
Multimedia Support
Networked Workstation
Web Server
Network Management Workstation
Authoring/Publishing
Development
Utilities

Comment 1 Michael Fulbright 2001-02-01 21:56:48 UTC
How much RAM is in your system?

Comment 2 Brent Nordquist 2001-02-01 22:05:39 UTC
48MB

Comment 3 Michael Fulbright 2001-02-01 23:39:31 UTC
Try booting the installer with the command:

 linux mem=32M

You are running out of ram. We have a test to see if you have too little RAM,
in which case we turn on swap.  Currently this only happens at 34M or less.
We probably need to move the little up.

Let me know if that works.

Comment 4 Michael Fulbright 2001-02-01 23:44:39 UTC
Note to ewt - we want the loader to tell us how much space ramdisks are using so
we can incorporate that into the decision to turn on swap early or not.

Comment 5 Erik Troan 2001-02-02 00:25:49 UTC
anaconda will now reduce the amount of memory in the machine by the amount of
memory used by the ramdisks.

We need to build trees to test this properly though. anaconda takes a --overhead
option which the loader should be computing properly.

Comment 6 Brent Nordquist 2001-02-02 14:05:42 UTC
That's it!  I got the "need to turn swap on" dialog this time.  Thanks for the
fast analysis.

Comment 7 Glen Foster 2001-02-02 23:06:11 UTC
This defect is considered MUST-FIX for Florence Release-Candidate #1

Comment 8 Michael Fulbright 2001-02-05 21:51:45 UTC
Needs to fix ewt's test.

Comment 9 Michael Fulbright 2001-02-06 22:01:02 UTC
Still run out of memory - probably need to bump up threshold for enabling swap
early.

Comment 10 Michael Fulbright 2001-02-08 17:48:20 UTC
Need to have different criteria for text and gui installs too, since X eats ram.

Comment 11 Michael Fulbright 2001-02-27 02:31:27 UTC
Have not had any additional reports of problems. We fixed the GUI install to run
in 48M w/o having to load swap early.


Note You need to log in before you can comment on or make changes to this bug.