Bug 255281 - rpm falsely reports successfull install on read-only /boot
rpm falsely reports successfull install on read-only /boot
Status: CLOSED DUPLICATE of bug 186945
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-26 15:01 EDT by Dean Mander
Modified: 2014-01-21 17:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-13 15:10:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dean Mander 2007-08-26 15:01:29 EDT
Description of problem:

Request for more robust kernel .rpm file.

Today, an upgrade of the kernel-package on a system with read-only /boot
partition, renders the system unbootable.

You can successfully (according to yum) install the kernel package on such a
read-only /boot. It will update the grub.conf and next boot it won't find the
non-installed kernel (when using the default grub choice) --> can't startup.

Version-Release number of selected component (if applicable):
kernel (all)

How reproducible:
always when kernel update available


Steps to Reproduce:
1. mount /boot as read-only
2. yum update kernel
3.
  
Actual results:
$ yum update kernel
<snip>
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: kernel                       ######################### [1/1]
error: unpacking of archive failed on file
/boot/System.map-2.6.22.4-65.fc7;46cfe671: cpio: open

Installed: kernel.x86_64 0:2.6.22.4-65.fc7
Complete!

Expected results:
I would expect the package to check if /boot is writable, 
if no, a transaction check error and a failure of the package update.

Additional info:
Comment 1 Jarod Wilson 2007-08-26 22:52:05 EDT
> You can successfully (according to yum)

That would suggest a yum bug, not a kernel bug.

> install the kernel package on such a
> read-only /boot. It will update the grub.conf and next boot it won't find the
> non-installed kernel (when using the default grub choice) --> can't startup.

Erm, grub.conf is on /boot so how would it have been updated if /boot was read-only?
Comment 2 Panu Matilainen 2007-08-27 13:27:25 EDT
This is a dupe of bug 186945 except that's against devel and this for F7 - yum
can catch this error if it wants to and IIRC yum 3.2.3 already does.
Comment 3 Jeremy Katz 2007-09-13 15:10:59 EDT

*** This bug has been marked as a duplicate of 186945 ***

Note You need to log in before you can comment on or make changes to this bug.