Bug 25553 - pread function versioned incorrectly
pread function versioned incorrectly
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-01 17:36 EST by Ben LaHaise
Modified: 2016-11-24 10:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-01 17:36:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben LaHaise 2001-02-01 17:36:43 EST
Compiling the following test program on an RH7 or 7.1beta machine results
in a program that does not run on a 6.2 box, even though the pread function
definition has not changed.

gcc -Wall -lpthread -lrt -o pread_test pread_test.c

int main()
{
	char buf[256];
	pread(0, buf, 0, 0);
	return 0;
}
Comment 1 Jakub Jelinek 2001-02-02 10:43:40 EST
It has changed, because in glibc 2.1.3 and below it had no linuxthreads
wrapper. And no matter what, symbol versioning is about upward binary
compatibility so older binaries work with newer libc, not vice versa.
pread and family could not be put into GLIBC_2.1.3 because 2.1.3 was released,
and e.g. rpm would be severely confused if we started adding symbols @GLIBC_2.1
now.

Note You need to log in before you can comment on or make changes to this bug.