Bug 255541 - Caret switches to different tab when a new IRC PM tab opens
Caret switches to different tab when a new IRC PM tab opens
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pidgin (Show other bugs)
7
All All
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-26 19:08 EDT by Ignacio Vazquez-Abrams
Modified: 2008-03-11 08:57 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.4.0-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-11 08:57:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ignacio Vazquez-Abrams 2007-08-26 19:08:44 EDT
Description of problem:
When someone PMs you in IRC and it opens a new tab the caret and your keyboard
focus will shift to a tab other than the one currently displayed.

Version-Release number of selected component (if applicable):
pidgin-2.1.1-1.fc7

How reproducible:
Every time

Steps to Reproduce:
1. Have someone in IRC PM you after having closed any tab open to them.
2. Notice that your typing no longer appears on the tab currently displayed.
  
Actual results:
New keystrokes are registered on a different tab.

Expected results:
Keystrokes should be registered on the currently displayed tab.

Additional info:
In my case it appears on the tab 2 behind the current one. I also coincidentally
have 2 tabs open to a server different from the current tab and the network I'm
being PMed from.
Comment 1 Ignacio Vazquez-Abrams 2007-09-27 08:19:14 EDT
pidgin-2.2.0-2.fc7 exhibits the same problem, plus it doesn't switch to a new
tab opened via /join.
Comment 2 Stu Tomlinson 2008-03-09 14:13:34 EDT
I am unable to reproduce the caret switching problem with Pidgin 2.4.0, could
you confirm if this is fixed?
Comment 3 Ignacio Vazquez-Abrams 2008-03-10 17:28:01 EDT
The main issue is fixed. It still doesn't switch on /join, but I'm not sure if
that's desired behavior or not.
Comment 4 Stu Tomlinson 2008-03-11 08:57:18 EDT
Not switching to a new tab on /join is not a bug, but requesting that could be
considered a feature request. It'll be hard to implement though, as we need to
be sure new conversations initiated by others don't cause unwanted focus
switching. If you'd like this I suggest you file a separate enhancement request
(it'd be better filed with Pidgin upstream as not many developers track Red
Hat's bugzilla).

Note You need to log in before you can comment on or make changes to this bug.