Bug 25571 - Ethernet card doesn't work after install
Ethernet card doesn't work after install
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
Brock Organ
Florence RC-1
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-01 19:37 EST by Michael Young
Modified: 2007-04-18 12:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-06 16:53:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Young 2001-02-01 19:37:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m18) Gecko/20001108
Netscape6/6.0


The ethernet card (an ne2000 compatible card) didn't work after a complete
install. Comparison with log files saved from Redhat6.2 suggests the line
"alias eth0 ne" was missing from /etc/modules.conf. Adding this line fixed
the problem.

Reproducible: Didn't try
Comment 1 Erik Troan 2001-02-02 14:23:29 EST
did you ftp/http install?
Comment 2 Michael Young 2001-02-02 15:33:10 EST
Yes, I installed using ftp (without problems once I had found the drivers disk).
Comment 3 Glen Foster 2001-02-02 18:00:40 EST
We (Red Hat) should really fix this before next release
Comment 4 Panic 2001-02-06 20:16:18 EST
This looks like Bug# 25774.
Comment 5 Michael Young 2001-02-07 08:37:31 EST
There are certainly similarities with bug 25774. I do have an ISA card (I am not
sure of the make), but in my case PnP is turned off (due to other OSs on the
same machine), and it has a fixed io setting which I entered during install
(io=0x300). Also I used dhcp throughout (atlhough the IP address is actually
static). The modules.conf file had only two lines after install "options ne
io=0x300" and "alias parport_lowlevel parport_pc".
Comment 6 Michael Fulbright 2001-02-08 13:23:12 EST
Brock do we have any ne2000 like cards to test.

This sounds like a kernel issue.
Comment 7 Tim Waugh 2001-02-08 18:52:45 EST
I have one of these cards, and it works fine here with 'linux expert' install
and a driver disk with an FTP installation.

I think the thing here is that you always used to have to install in expert mode
to get the card detected (the driver used to be on the main disk).  So I just
did that, knowing that I wanted my network card to work.
Comment 8 Panic 2001-02-08 19:50:32 EST
Respectfully, I would disagree that this is a kernel issue, although I think it
may be related.  Look at what we know:

1) Adding the missing "alias eth0 ne" line fixes the problem;

2) The Expert install with driver disk works properly;

3) A non-PnP card has the same issue;

4) A normal install produces a half-written /etc/modules.conf -- the options
line is there, but the alias line is not, even on a card that was explicitly
configured.

My SWAG would be that the installer isn't writing the modules.conf file properly
in this case, with the cause of that behavior being unknown.  It would make more
sense to me if nothing was written to the /etc/modules.conf, but the interface
was configured during installation.
Comment 9 aaron 2001-02-12 16:41:09 EST
This goes for the following cards using both a text install as well as 
graphical install.

realtek 8139

Manually updating /etc/modules.conf is the fix
Comment 10 Michael Fulbright 2001-02-13 22:40:43 EST
If I understand correctly, in a non-expert install you are prompted to select
the NIC type because kudzu cannot detect it. You enter the proper type, the
install works, and then on reboot the modules.conf is incorrect so networking fails.

If you do a expert install, specify the card, yada yada, then reboot, it works fine?

Comment 11 Michael Young 2001-02-14 13:08:31 EST
I had a blank partition just big enough for a minimal install, so I have been
doing some testing. In my tests even an expert install dosen't necessarily add
the "alias eth0 ne" line, which was the case when I didn't try to add any extra
drivers when given the option. If I did try to add extra drivers from the
drivers disk, the ne1000/2000 compatible option wasn't listed, but when I
pressed the back button, it had auto-detected the card, and after the install
the "alias eth0 ne" had been added. It is almost as if it needed to be reminded
what drivers it knew about. Incidentally, I don't know if it is relevant, but my
PC only has 32Mb memory.
Comment 12 Tim Waugh 2001-02-15 07:49:30 EST
With the expert install there is an extra screen: the 'Do you want to add extra
device drivers' one, with 'NE2000' already there.  I think that's the
difference.
Comment 13 Erik Troan 2001-02-22 14:37:47 EST
The problem is that for ftp/http/hd installs, the install forgets about drivers
it loads at the beginning (saves real space on the disk), so it also forgets to
write those items to /etc/modules.conf (for the same reason it doesn't write
things like nfs.o and sunrpc.o out; ne.o and 8390.o look the same to it then; it
doesn't even know ne.o is a networking module in fact).

It doesn't affect pci cards because kudzu puts things back for us using the same
probing code, but it does affect cards that aren't probed. This is a pretty big fix.
Comment 14 Erik Troan 2001-03-06 16:53:19 EST
I found a nice fix for this.

Note You need to log in before you can comment on or make changes to this bug.