Bug 255801 - iwl3945 doesn't re-connects after a disconnect
iwl3945 doesn't re-connects after a disconnect
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
medium Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-27 01:15 EDT by Deependra Singh Shekhawat
Modified: 2008-02-13 15:31 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-13 15:31:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Deependra Singh Shekhawat 2007-08-27 01:15:28 EDT
Description of problem:
iwl3945 doesn't tries to re-connect to my wireless access point after it gets
disconnected from the access point.


Version-Release number of selected component (if applicable):
kernel-2.6.22.4-65.fc7

How reproducible:
Disable all networkManager stuff and use system-config-network to configure the
wireless device. ReBoot fedora7 latest updated laptop having intel wireless
card. I am using iwl3945 driver. Use internet in it and when suddenly power goes
down and my wireless router switches off I am disconnected. This far is okay.
But later when power comes back and the wireless access point starts all over
again my laptop doesn't find it and cannot connect to the wireless router
automatically. 
I have to:
rmmod -r iwl3945
modprobe iwl3945
and then it's re-connects me to the wireless router.

I had no such problem with ipw3945 which use to automatically re-connect me
after any such failure.

I probably think it's a upstream bug and I am not sure whether this has been
reported here or at upstream so I thought it might be useful.

Any more info needed please feel free to ask.
Comment 1 John W. Linville 2007-09-28 10:17:49 EDT
I'm curious if rather than the rmmod/modprobe you just did 'iwconfig wlan0 
essid <essid>' (where <essid> is of course the SSID for your wireless LAN) 
does that restore the connection?
Comment 2 Deependra Singh Shekhawat 2007-09-28 12:36:43 EDT
No. I haven't tried iwconfig wlan0 essid <essid> command. Because rmmod/modprobe
worked for me.
I will be trying that too soon and will update here.

Thanks
Comment 3 Christopher Brown 2008-01-13 13:36:33 EST
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.
Comment 4 John W. Linville 2008-02-13 15:31:56 EST
Closed due to lack of response...

Note You need to log in before you can comment on or make changes to this bug.