Bug 2561 - iris-ansi-net missing from terminfo (exists in termcap)
iris-ansi-net missing from terminfo (exists in termcap)
Status: CLOSED NEXTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: ncurses3 (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-05 04:05 EDT by ariel
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-27 16:37:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description ariel 1999-05-05 04:05:23 EDT
[Note: This problem may exist in more than one Red Hat
 distribution (I picked raw Hide since it's the latest)
 and in more than one 'ncurses']


When logging in from any IRIX system to a Red Hat
linux system, $term is set by default to 'iris-ansi-net'
which doesn't exist in your terminfo database
(although it _does_ exist in /etc/termcap as an alias
for iris-ansi.)  This results in all curses based program
complaining about an unrecognized terminal and "using
dumb terminal settings".


A quick workaround is to create a link from iris-ansi-net
to iris-ansi (which already exists in the distribution).

Please add this in your next fix to ncurses/ncurses3
or whatever.  Thanks!
Comment 1 Cristian Gafton 1999-07-28 03:36:59 EDT
assigned to pbrown
Comment 2 Preston Brown 1999-08-27 16:37:59 EDT
this will be fixed in the next release (6.1).

Note You need to log in before you can comment on or make changes to this bug.