Bug 25611 - Installer can't write the boot loader
Installer can't write the boot loader
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-02-01 21:46 EST by Juan A. Burgos
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-06-12 23:37:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Juan A. Burgos 2001-02-01 21:46:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (Win95; U)

When instaling the instalaltion hangs before writing the boot loader and error apears in tty1 saying that /dev/hda can be opened,

Reproducible: Always
Steps to Reproduce:
1.custom instalation
2.partitioning with 6 partitions the first hd (hda)
3.two seagate 13Gb hard drives on first ide channel 	

Actual Results:  Instalation dont write the boot loader saying it can open /dev/hda, the system can4t boot up, but no error were reported on 
anaconda screen.

Expected Results:  boot loader installed

two seagete 13Gb HD on first ide chanel where partitioned, / is hda1 (768Mb) no boot partition. boot loader selected on MBR. Via chipset Iwil 
VD133 motherboard

workarround: with all the same installation parameters, removing the slave drive (only partitions /export & /home were in it)
the installation ends sucessfully.

the problem seems to be the way the instaler try to access the harddrive hda.
Comment 1 Michael Fulbright 2001-02-06 15:29:33 EST
Please give the partitions and mount points (with sizes) that caused the
original problem. Geometries of the two drives would be helpful as well.
Comment 2 Juan A. Burgos 2001-02-08 06:47:24 EST
the geometry of both disks is the same 

geometry =  1583/255/63 sectores = 25434228 start = 0

the partition table is:

Disk /dev/hda: 255 heads, 63 sectors, 1583 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1        98    787153+  83  Linux
/dev/hda2            99      1583  11928262+   5  Extended
/dev/hda5            99       490   3148708+  83  Linux
/dev/hda6           491       752   2104483+  83  Linux
/dev/hda7           753       948   1574338+  83  Linux
/dev/hda8           949      1144   1574338+  83  Linux
/dev/hda9          1145      1275   1052226   83  Linux
/dev/hda10         1276      1406   1052226   83  Linux
/dev/hda11         1407      1537   1052226   82  Linux swap

Disk /dev/hdb: 255 heads, 63 sectors, 1583 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hdb1   *         1       779   6257286   83  Linux
/dev/hdb2           780      1583   6458130    5  Extended
/dev/hdb5           780      1558   6257286   83  Linux

Comment 3 Michael Fulbright 2001-02-08 12:47:11 EST
Please also attach the mount points you were trying to use when the problem
Comment 4 Juan A. Burgos 2001-02-13 04:34:24 EST
sorry i forgot it:) here u are

Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/hda1               774040     69908    664776  10% /
/dev/hda10             1035660       388    982664   1% /home
/dev/hda9              1035660        84    982968   1% /tmp
/dev/hda5              3099260   1932744   1009084  66% /usr
/dev/hda6              2071384       444   1965716   1% /usr/local
/dev/hda7              1548096     32164   1437216   3% /var
/dev/hda8              1548096       388   1468992   1% /var/log
/dev/hdb1              6158916        20   5846032   1% /var/spool/mail
/dev/hdb5              6158916        20   5846032   1% /export

Comment 5 Michael Fulbright 2001-02-21 18:10:47 EST
Do you see any errors on VC3 or VC4 when this occurs (cntl-alt-f3 and -f4)?
Comment 6 Juan A. Burgos 2001-02-21 18:19:00 EST
it just says it can4t open /dev/hda.

i miss '4t' in the first comment.
Comment 7 Michael Fulbright 2001-04-20 11:28:21 EDT
This is an odd occurance. I have not seen this occur with our systems in our
testing.  Does the system work if you reattach the slave driver after you have
successfully installed Linux?
Comment 8 Juan A. Burgos 2001-04-20 11:46:49 EDT
yes it works fine, the problem was found during intall, when anaconda tried to install the system loader
in the hard disk, it seems like if he couldn4t select between the two disk where to write as they were
the same type of disk.
Comment 9 Troels Riis 2001-04-27 08:16:24 EDT

I was just going to report almost the same error as 25611. Here is my situation.

I have many PC's running Linux which I am now reinstalling with RH7.1. However on two of the machines I run into a similar problem. Both machines have 
an Intel SE440BX motherboard with a PII-400. Otherwise they have different discs and hardware - so I wonder if it is something to do with the 

Both machines have run fine with RH 6.2 and 7.0, however I had problems with 7.0.91 Wolverine, but I figured ... well its a beta, so I waited for 7.1

All the installation goes fine until the post installation process. Then I get a:

"An error occured while installing the bootloader"
" We highly recommend you make a recovery floppy....."
"The error reported was
Fatal: open /dev/hda: No such file or directory"

Then I have no choice to proceed to the floppy creation. I insert an floppy and I get a new error:

"An error occured while making the boot disk"
"please make sure that there is a formatted
floppy in the floppy drive"

and yes I have tried several floppys and I know the drive works because I have also tried installing with boot.img on a floppy.

and then I am pretty dead !!!!!!!

Here is the install story. I start either directly or by specifying
linux hda=3308,16,63

Here is my configuration in fdisk: (IBM 1.6GB DJAA 31700)
Disc is on primary master IDE. CDROM on secondary master.

Disk /tmp/hda1: 16 heads, 63 sectors, 3308 cylinders
Units = cylinders of 1008 * 512 bytes

/tmp/hda1   *      1   66    33232+    83   Linux
/tmp/hda2         67  587   262584     82   Linux swap
/tmp/hda3        588 3308  1371384     83   Linux

mounted as

/boot         hda1    32M       Linux native
<Swap>        hda2   256M       Linux swap
/             hda3 1339M        Linux native

I set it to install LILO on MBR and default use linear mode (I also tried lba32 and non-linear and no lilo combinations).

Then it goes through the installation fine until the bootloader problem and rescue disc described above.
The only option is then to skip the floppy creation and it reboots with no hope at all to get in.

PLEASE I AM DESPERATE. One of the computers is a server I NEED to install asap.

First I thought It mights have something to do with some new big 45G discs I had in and tried to do SW raid on the one computer,  or a dual boot 
machine with a 10 GB Windoze on the other. The last had some 1024 cylinder limit but was able to fix with lba32 on 7.0. Therefore I basically tried all 
combinations of bios settings (LBA) and linear, lilo. I even tried not to set it to install lilo to plan to use LoadLin to get around it, but... still no floppy boot 

Therefore I stripped the server machine to be as simple as possible with only this small 1.7 GB disc with simple partitioning...... no way it will works.

I have tried to install RH 7.0 first - fine. Then I do an upgrade to 7.1 which I then can get to work ??????? However Iam very uncertain of the machine I 
then have. Will it keep old garbage packets from 7.0., and espicially: What about /etc - is this updated to the new default setting in 7.1 (security) or does 
it keep the current settings from the temporary 7.0 install ??? Please this would help me to get on.

I like Redhat a lot, but this is really taking my time, so I really hope sending in this information will help with a fix - SOON, please.

Thank you,

Troels Riis

Note You need to log in before you can comment on or make changes to this bug.