Bug 25620 - XFree86 "Test Setting" crawls, freezes
XFree86 "Test Setting" crawls, freezes
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
Brock Organ
Florence Gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-02 01:05 EST by roystgnr
Modified: 2007-04-18 12:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-19 18:50:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description roystgnr 2001-02-02 01:05:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.0-0.99.11 i686; en-US; m18)
Gecko/20010130


Configuring X on a new fisher install, when pressing the "test these
settings" button, the "can you see this box" dialog is preceded by an
excruciatingly slow Gnome startup, and followed by an apparant system freeze

Reproducible: Always
Steps to Reproduce:
1.  Start a new server install
2.  Configure X to start in 1024x768x24bpp mode
3.  Click "Test Setting"
	

Actual Results:  After approximately 30 seconds, the X background appears.
 The mouse cursor is initially responsive, but soon freezes.
After 2-3 more minutes (during which the only sign of system activity was
the blinking CD-ROM light), a bare Gnome install appears,
(Home/Trash/www.redhat.com/RHN Registration on desktop,
Foot/Help/Term/Config/Netscape/Tasklist/Desk Guide on panel, blue embossed
redhat logo background), and the mouse cursor becomes responsive again.

Shortly thereafter, the plain "Can you see this/do you want to keep these
settings" dialog box appears.  We clicked yes.

The dialog box disappeared, and shortly thereafter the mouse again became
unresponsive.  After ~5 minutes with no activity (including from the CD-ROM
and hard drive), we were able to use Alt-SysRq-B to do a soft reboot.

This is of course an easily worked around problem, the solution being not
to click "Test Setting".



Expected Results:  Was bringing up the whole Gnome desktop (apparantly
running off of the filesystem mounted off CD) to display the "test
settings" dialog intentional?

The video hardware in this box (correctly autodetected) is a Matrox G200
with 8MB of RAM.  The monitor (incorrectly autodetected as "DDC Probed
Monitor/STC02c7" with much inferior settings, then manually changed to be
correct) is a Sampo AlphaScan 17.  The CD-ROM is a 16x drive.  We have
reproduced this twice, and are currently installing without testing X settings.
Comment 1 Michael Fulbright 2001-02-02 14:12:07 EST
It was NOT bringing up GNOME, that would take forever :)

We have a known problem with the loopback filesystem from CDROM being slow.

Comment 2 Erik Troan 2001-02-02 14:22:59 EST
I don't believe this is a speed problem w/ loopback.

How long did it take your machine to boot up in the graphical install to begin
with?
Comment 3 Glen Foster 2001-02-02 18:08:34 EST
We (Red Hat) should really fix this before the next release.
Comment 4 roystgnr 2001-02-02 18:52:47 EST
If it wasn't bringing up Gnome, it certainly brought up a good screenshot.  I
suppose we never did try clicking on anything but the "can you see this" dialog box.

Initially booting into the GUI installer took longer than 7.0 on both machines
we have fisher running on, but it was still on the order of 30 seconds after the
BIOSes booted from CD.

One potential complicating factor I was unaware of before: my roommate was
installing on top of a previous Debian installation, and apparantly did not
reformat the Linux partitions during the Red Hat install; this caused problems
with mismatched UIDs/usernames in files left in /home from Debian.  I'll see if
I can convince him to try the fisher install again and format this time.
Comment 5 roystgnr 2001-02-03 00:07:52 EST
We just tried to reproduce the problem again; a few notes:

This time, it didn't make it past the epileptic default X background; after 
about one minute, the system returned to a text console with the error message 
"install exited abnormally", then did the usual shutdown: termination signals, 
kill signals, disabling swap, unmounting.  Some interesting error messages:

"/mnt/source umount failed (16)"

On VT 4, "<3>Out of Memory: Killed process 56 (anaconda)."

None of the hard drive partitions appeared to have been mounted, so that 
couldn't be a contributing factor.  We are installing from a cheap CD-R (of an 
md5summed iso, at least), so can't rule out a flaky burn; however the same 
CD-R was used to successfully install fisher on this computer (skipping the X 
settings test) and upgrade from RH7 on another system successfully.
Comment 6 David Sainty 2001-02-14 17:37:36 EST
Right... so how much RAM is the machine supposed to have?  can you start the
installation, and give us the output of "cat /proc/meminfo"? This will tell us
how much memory Linux thinks you have.

Also, what is the graphics card? Some more information on the hardware might
also be useful.


David S..
Comment 7 roystgnr 2001-02-14 19:37:37 EST
The computer has 64MB RAM, and an (8 MB video RAM) Matrox G200 graphics card.
It was configured with a 92MB swap partition.
We'll find out how much RAM the installer autodetects shortly.
Comment 8 Michael Fulbright 2001-02-15 12:21:50 EST
We've made some changes that reduce the amount of RAM used early by the
installer. I think this will address your issue for a 64M machine.

Note You need to log in before you can comment on or make changes to this bug.