Bug 256401 - packaging error(?)
packaging error(?)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-samba (Show other bugs)
7
All All
medium Severity low
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-27 09:41 EDT by Stephanos Manos
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 1.2.52-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 23:24:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephanos Manos 2007-08-27 09:41:53 EDT
Description of problem:
rpm -V system-config-samba reports the following

[root@viper ~]# rpm -V system-config-samba
missing     /usr/share/system-config-samba/addUserWin.pyc
missing     /usr/share/system-config-samba/basicPreferencesWin.pyc
missing     /usr/share/system-config-samba/mainWindow.pyc
missing     /usr/share/system-config-samba/samba-share.pyc
missing     /usr/share/system-config-samba/sambaBackend.pyc
missing     /usr/share/system-config-samba/sambaDefaults.pyc
missing     /usr/share/system-config-samba/sambaParser.pyc
missing     /usr/share/system-config-samba/sambaToken.pyc
missing     /usr/share/system-config-samba/sambaUserData.pyc
missing     /usr/share/system-config-samba/sambaUserWin.pyc
missing     /usr/share/system-config-samba/sambaoptionscheck.pyc
missing     /usr/share/system-config-samba/shareWindow.pyc
missing     /usr/share/system-config-samba/system-config-samba.pyc

Version-Release number of selected component (if applicable):
system-config-samba-1.2.47-1.fc7

How reproducible:
Always

Steps to Reproduce:
1. Just do a clean install of f7
2. update the system
3. run rpm -V system-config-samba
  
Actual results:
The above error

Expected results:
Nothing in the output of rpm -V

Additional info:
IMHO the following should be removed from the spec file

%preun
if [ -d /usr/share/system-config-samba ] ; then
  rm -rf /usr/share/system-config-samba/*.pyc
fi

since according to the python packaging guidelines is not needed in current
versions of fedora
Comment 1 Nils Philippsen 2007-08-27 09:53:48 EDT
Thanks for spotting this. I've fixed this in the upstream repository but
packaging that change will have to wait because there are some bugs that need to
be fixed first. Mind that updating to the next version when it's there won't
help  for the first time because the %preun commands come from the old version
that still removes the *.pyc files.
Comment 2 Stephanos Manos 2007-08-28 06:13:38 EDT
I see it's been fixed and rebuild for rawhide.
Is there going to be a rebuild with the fixes for f7?
Comment 3 Nils Philippsen 2007-08-28 07:10:21 EDT
I'll wait for some new translations, but I plan to build a fixed version for F7.
That's why this ticket is ASSIGNED, not CLOSED.
Comment 4 Fedora Update System 2007-09-07 13:16:47 EDT
system-config-samba-1.2.50-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2007-09-10 12:52:24 EDT
system-config-samba-1.2.51-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Stephanos Manos 2007-09-10 19:08:34 EDT
Fixed.
Comment 7 Fedora Update System 2007-09-17 23:24:14 EDT
system-config-samba-1.2.52-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.