Bug 2564825 - CVE-2026-57201 asterisk: asterisk: Denial of Service via stack buffer overflow in H.323 trace logging [epel-8]
Summary: CVE-2026-57201 asterisk: asterisk: Denial of Service via stack buffer overflo...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: asterisk
Version: epel8
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: EPEL Packagers SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: {"flaws": ["494f62fb-e1a8-4d0a-b362-6...
Depends On:
Blocks: CVE-2026-57201
TreeView+ depends on / blocked
 
Reported: 2026-11-02 09:53 UTC by gkamathe
Modified: 2026-11-02 13:03 UTC (History)
4 users (show)

Fixed In Version:
Clone Of:
Environment:
Last Closed: 2026-11-02 13:03:24 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description gkamathe 2026-11-02 09:53:34 UTC
Disclaimer: Community trackers are created by Red Hat Product Security team on a best effort basis. Package maintainers are required to ascertain if the flaw indeed affects their package, before starting the update process.

Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, a stack buffer overflow in the H.323 `ooTrace()` trace-logging function can occur when unbounded `vsprintf` writes into a fixed `2048-byte buffer`. A remote attacker may send a carefully crafted packet that causes the Asterisk process to crash. The `chan_ooh323` addon channel driver must be explicitly compiled and installed, which is not the default, and its port must be publicly reachable. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3.

Comment 1 Peter Lemenkov 2026-11-02 13:03:24 UTC
Not affected. The flaw is in the H.323 trace logging of the chan_ooh323 addon (addons/ooh323c/src/ootrace.c). The asterisk package on this branch is built without chan_ooh323 (it is disabled in menuselect), so the vulnerable code is not shipped in any asterisk-18.26.4 subpackage.


Note You need to log in before you can comment on or make changes to this bug.