Bug 25651 - Graphical Installation failure under VMware
Graphical Installation failure under VMware
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86-Servers (Show other bugs)
7.1
i386 Linux
low Severity low
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-02 03:30 EST by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-02 03:30:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-02-02 03:30:45 EST
When installing fisher in a virtual machine under VMware (www.vmware.com),
fisher fails to start X  and falls back to text mode.  (Hardly an important
problem.)  Only error reporting is on the main virtual terminal which
quickly dissappears as the menu configution method comes up.  Text is from
the mouse detection:
----
Found a Generic - 3 Button Mouse (PS/2)
Probed X server is None
unknown
We can use framebuffer
fb_check returned with z value unknown
We can use framebuffer
0
Using X server /usr/X11R6/bit/XF86_FBDev
Cant open /dev/fb0
X Startup failed. Falling back to text mode
-----

I had to write this down and retype so sorry if there are errors.

Host machine (the one running VMWare) is:
	- Intel 815EEA motherboard
	- Pentium III 933
	- 2 * 20Gb + 1 * 30 Gb hard drives
	- DVD-ROM drive
	- 512 Mb memory
	- dec tulip ethernet card
	- RedHat 7.0
	- Linux kernel 2.4.1 with upgraded associated utilities.

Virtual machine was set up for:
	- 2 * 2 Gb hard disks
	- CD-ROM enabled
	- 64 Mb memory
	- ethernet enabled
	- floppy enabled
Comment 1 Mike A. Harris 2001-02-06 16:01:23 EST
VMware is not a supported installation platform target.
Comment 2 Bill McCarty 2001-05-10 20:45:16 EDT
The reason the vmware graphical install fails is that the Seawolf anaconda 
never falls back to VGA16. It uses the framebuffer stuff, even if "no 
framebuffer" is specified on the boot menu. This appears to me to be a logic 
error in anaconda. I hacked the code a little and managed to create a CD that 
*does* fall back to VGA16. The vmware install works fine with my CD. That is, 
if you can call VGA16 "fine" <grin>. In any case, as I see it, the fact that 
vmware is not a supported platform seems moot. The source of this problem has 
nothing to do with vmware or any peculiar characteristics of vmware.
Comment 3 Mike A. Harris 2001-05-10 20:57:12 EDT
Open a request for enhancement bug report against "anaconda" and attach your
enhancements to it.  Our instller team will go over them and decide wether
or not to add it in.

Note, I didn't say that VMware would not install because of bugs in VMware,
I said VMware is not a supported installation target.  This means that if
people try to install Red Hat Linux into a VMware virtual machine and it works,
that is great.  If it does not work, it is not considered a bug because
VMware is not a supported platform.  Our supported platforms are i386 and
alpha currently, and a virtual machine running on i386 is not considered
an i386 because it is a virtual environment.  There _are_ many issues that
_can_ come up with such an environment, and we do not have the resources
to cover installation on all of those possible edge cases.  Therefore, wether
a bug is in VMware or in Red Hat Linux when installed to VMware, it doesn't
make any difference because it is not a supported installation target.

That said, it doesn't mean that we will not fix something if it is reported
to us, preferably with a patch to fix it.  What it does mean is that we
will not personally expend any engineering effort to troubleshoot and solve
problems with unsupported installation targets.  As I said though, we gladly
accept patches.  If your changes are clean, and the anaconda team likes
the idea, perhaps they will add it into a future release of Red Hat Linux.

Personally I think it is _good_ if Red Hat Linux installs to VMware even if
we wont support such configuration, and I'm sure that others feel the same
as you and I.

Note You need to log in before you can comment on or make changes to this bug.