This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 256581 - RFE: Have bind startup go into the background?
RFE: Have bind startup go into the background?
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: bind (Show other bugs)
4.0
All All
medium Severity low
: ---
: ---
Assigned To: Adam Tkac
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-27 10:28 EDT by Chris Adams
Modified: 2013-04-30 19:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-17 13:15:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Adams 2007-08-27 10:28:27 EDT
I have several servers (some RHEL, some Fedora) running bind that have several
thousand zones.  The problem is that during bootup, bind takes a long time to
load the zones (over two minutes on one particular server), and nothing else can
happen during that time.  Since bind starts before most other services
(including sshd), this is kind of annoying.

Would it be possible to background the bind startup in the init script?  I know
that has issues as well, but not even being able to SSH in for several minutes
can be a problem.
Comment 1 Adam Tkac 2007-08-31 04:49:59 EDT
Start BIND on background by default will be never default behavior. But I'm
going to check if it's possible add option to initscript for this issue.
Comment 2 Adam Tkac 2007-08-31 05:10:01 EDT
Hm, this option will break all and I'm against it. Sophisticated solution will
be port DLZ driver (http://bind-dlz.sourceforge.net/ , part of BIND-9.4 >=) to
RHEL4 and use it. What's your opinion?
Comment 3 Chris Adams 2008-01-07 22:03:58 EST
That looks interesting, but it doesn't really help me; all my DNS config is in
CVS for revision control, so changing it to a database, LDAP, etc. would be a
major operation.

Oh well, for now, I'm copying /etc/init.d/named to named-auth and changing the
priority to 99.
Comment 4 Adam Tkac 2008-01-17 13:15:48 EST
(In reply to comment #3)
> That looks interesting, but it doesn't really help me; all my DNS config is in
> CVS for revision control, so changing it to a database, LDAP, etc. would be a
> major operation.
> 
> Oh well, for now, I'm copying /etc/init.d/named to named-auth and changing the
> priority to 99.

This cannot be released in update, it will break many configuration which
depends on bind as local nameserver. If you think that DLZ is solution for you,
please reopen. Closing as notabug

Note You need to log in before you can comment on or make changes to this bug.