Bug 256761 - anaconda fails on manually configuring network interface when ipv4 disabled
anaconda fails on manually configuring network interface when ipv4 disabled
Status: CLOSED DUPLICATE of bug 235824
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
All All
medium Severity low
: ---
: ---
Assigned To: David Cantrell
Depends On:
  Show dependency treegraph
Reported: 2007-08-27 11:38 EDT by Karel Volný
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-09-13 18:20:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2007-08-27 11:38:06 EDT
Description of problem:
When configuring the network interface, there is an option to select DHCP or 
manual configuration. Then there is a checkbox "Enable ipv4". When this 
checkbox is not selected, it is impossible to enter IP address for the given 
interface. After clicking OK for the dialog, anaconda reports exception, 
complaining about missing IP address and the installation halts.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Run installation of RHEL from optical media.
2. Bring up the box for configuring network interface (e.g. by trying to add 
iscsi target during disk partitioning).
3. Uncheck the use dhcp box and use ipv4 box.
4. Click OK.
Actual results:
The installation stops, reporting missing address exception.

Expected results:
a) Recover from the error, allowing to correct the mistake
b) Do not allow user to uncheck the box, if the address is really required.

Additional info:
I tried it on RHEL 5 Server and RHEL 5.1 snapshot 0822. Sorry for not 
providing exact messages, I have troubles running kvm console - just ask if 
you need something.
Comment 1 David Cantrell 2007-08-27 11:41:11 EDT
The iSCSI netconfig dialog box is not like any of the other netconfig dialog
boxes in anaconda.  Easiest fix here is either remove the Enable IPv4 checkbox
or force it to be selected all the time.  That would be minimal UI change and
I'm leaning towards having it there, but forcing it to be selected all the time.

Flagging for 5.2.  Thanks for the report.
Comment 2 David Cantrell 2007-09-13 18:20:23 EDT
I just worked on this for the past two days for RHEL 5.1.  I'm pretty sure this
is the same bug, so I'm duping it.
Comment 3 David Cantrell 2007-09-13 18:20:53 EDT

*** This bug has been marked as a duplicate of 235824 ***

Note You need to log in before you can comment on or make changes to this bug.