Bug 256921 - Stellarium refuses to start
Stellarium refuses to start
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: stellarium (Show other bugs)
7
x86_64 All
medium Severity high
: ---
: ---
Assigned To: Jochen Schmitt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-27 11:57 EDT by Mattia Verga
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-02 16:18:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mattia Verga 2007-08-27 11:57:48 EDT
Description of problem:
After upgrading to stellarium 0.9.0 program doesn't start. In the same upgrade
I've upgraded also wt4 and qt4-x11. It gives the error:
Cannot mix incompatible Qt libraries

Version-Release number of selected component (if applicable):
stellarium.x86_64                        0.9.0-4.fc7
qt.x86_64                                1:3.3.8-4.fc7
qt.i386                                  1:3.3.8-4.fc7
qt4.i386                                 4.3.1-3.fc7
qt4.x86_64                               4.3.1-3.fc7
qt4-x11.x86_64                           4.3.1-3.fc7
qt4-x11.i386                             4.3.1-3.fc7


How reproducible:
Try to start the program

Steps to Reproduce:
1. Open terminal
2. Launch "stellarium"
  
Actual results:
-------------------------------------------------------
[ This is Stellarium 0.9.0 - http://www.stellarium.org ]
[ Copyright (C) 2000-2006 Fabien Chereau et al         ]
 -------------------------------------------------------
File search path set to:
 1) /home/marvin/.stellarium
 2) /usr/share/stellarium
config file is: /home/marvin/.stellarium/config.ini
Cannot mix incompatible Qt libraries
Comment 1 Mattia Verga 2007-09-01 12:27:40 EDT
I found the problem.

[marvin@marvin ~]$ ldd /usr/bin/stellarium | grep -i qt
        libQtOpenGL.so.4 => /usr/lib64/libQtOpenGL.so.4 (0x00002aaaaaadd000)
        libQtGui.so.4 => /usr/lib64/libQtGui.so.4 (0x00002aaaaad4b000)
        libQtCore.so.4 => /usr/lib64/libQtCore.so.4 (0x000000361ea00000)

libQtCore.so.4 is a link to libQtCore.so.4.3.1 while libQtGui.so.4 and
libQtOpenGL.so.4 are linked to libQtGui.so.4.3.0 and libQtOpenGL.so.4.3.0.
Changing these two links to the 4.3.1 version resolve the bug.
Comment 2 Jochen Schmitt 2007-09-02 16:18:41 EDT
This sound like an incorrectly installed Qt4. If that seems to be a general
issue with the QT4 package, please open a bug agains this component.


Note You need to log in before you can comment on or make changes to this bug.