Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 25709 - fdisk reboot needed
fdisk reboot needed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-02 08:36 EST by LENHOF
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 19:32:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description LENHOF 2001-02-02 08:36:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; SunOS 5.6 sun4m)


After making some changes with fdisk the computer need to be rebooted...
The mke2fs message displayed is not really explicit.

Reproducible: Always
Steps to Reproduce:

	[root@clf72av /root]# fdisk /dev/hda

The number of cylinders for this disk is set to 1292.
There is nothing wrong with that, but this is larger than 1024,
and could in certain setups cause problems with:
1) software that runs at boot time (e.g., old versions of LILO)
2) booting and partitioning software from other OSs
   (e.g., DOS FDISK, OS/2 FDISK)

Commande (m pour aide) : p

Disque /dev/hda : 240 tjtes, 63 secteurs, 1292 cylindres
Unitis = cylindres sur 15120 * 512 octets

Piriphirique Amorce    Dibut       Fin    Blocs   Id  Systhme
/dev/hda1   *         1       339   2562808+  83  Linux
/dev/hda2           340      1292   7204680    5  Etendue
/dev/hda5           340       353    105808+  82  Echange Linux

Commande (m pour aide) : n
Action de commande
   l   Logique (5 ou plus)
   p   Partition primaire (1-4)
l
Premier cylindre (354-1292, 354 par difaut) : 
Utilisation de la valeur par difaut 354
Dernier cylindre ou +size ou +sizeM ou +sizeK (354-1292, 1292 par difaut) :
+100M

Commande (m pour aide) : w
La table de partition a iti modifiie !

Appel de ioctl() pour relire la table de partition.
La relecture de la table a ichoui. Erreur  16 : Piriphirique ou ressource
occupi.
Riamorcez le systhme pour jtre s{r que la table de partition a iti mise `
jour.

AVERTISSEMENT: Si vous avez crii ou modifii
une partition DOS 6.x, reportez-vous au manuel de fdisk
pour plus d'informations.
Synchronisation des disques.
[root@clf72av /root]# fdisk -l /dev/hda

Disque /dev/hda : 240 tjtes, 63 secteurs, 1292 cylindres
Unitis = cylindres sur 15120 * 512 octets

Piriphirique Amorce    Dibut       Fin    Blocs   Id  Systhme
/dev/hda1   *         1       339   2562808+  83  Linux
/dev/hda2           340      1292   7204680    5  Etendue
/dev/hda5           340       353    105808+  82  Echange Linux
/dev/hda6           354       367    105808+  83  Linux
[root@clf72av /root]# mke2fs /dev/hda6
mke2fs 1.18, 11-Nov-1999 for EXT2 FS 0.5b, 95/08/09
/dev/hda6: Invalid argument passed to ext2 library while setting up
superblock
[root@clf72av /root]# 

AFTER REBOOTING.......IT WORKS NICE

[root@clf72av /root]# mke2fs /dev/hda6 
mke2fs 1.18, 11-Nov-1999 for EXT2 FS 0.5b, 95/08/09
Filesystem label=
OS type: Linux
Block size=1024 (log=0)
Fragment size=1024 (log=0)
26520 inodes, 105808 blocks
5290 blocks (5.00%) reserved for the super user
First data block=1
13 block groups
8192 blocks per group, 8192 fragments per group
2040 inodes per group
Superblock backups stored on blocks: 
        8193, 24577, 40961, 57345, 73729

Writing inode tables: done                            
Writing superblocks and filesystem accounting information: done
[root@clf72av /root]# 



Actual Results:  See above

Expected Results:  Don't need a reboot after making some changes with fdisk
Comment 1 Karsten Hopp 2001-02-05 10:47:34 EST
That's a limitation of the linux kernel. If you change the partition table
of a disk while one of its partitions is mounted, the kernel can't get the
new partition table.
Comment 2 LENHOF 2001-02-06 16:19:16 EST
Hi guys,

I'm a little bit surprised by yours response. For a personnal or a workstation
purpose reboot is just a question of two minutes.... By I want to enforce the
use in the society where I'm working - EDF in France with a contract with Sun -
I need this functionnality in order to use Linux for servers...

Indeed, with sun Solaris you don't need a reboot for just adding a partition...
And with this restriction we cannot use Linux so many times we use Solaris in
product environment. I think that more and more with the new things like LVM,
ReiserFS, ext3 ;-) , XFS and so an...we are going to need this...

So if you don't want to have a look on it...please send a mail to the guy which
is responsible of this part or give me an address where I can send an e-mail
about this problem...

I think this problem could be interesting to be solved for everybody !

Thanks for giving me a response.
Comment 3 LENHOF 2001-02-14 14:56:37 EST
I know this is not a bug....that's why I selected ENHANCEMENT... And I would
like to have a better answer or let this bug open until someone fix it in the
kernel...

Thanks
Regards

Jean-Yves LENHOF

Personnal E-Mail : lenh_jea@caramail.com
Professionnal E-Mail : lenhof@edf.fr
Comment 4 Crutcher Dunnavant 2001-03-27 15:40:14 EST
reclasify
Comment 5 Arjan van de Ven 2001-03-28 11:13:20 EST
Also, there are better partition-types (BSD for one) which behave better.
Comment 6 Alan Cox 2003-06-05 19:32:16 EDT
Closing - now we have LVM I guess its sufficiently enhanced 8)

Note You need to log in before you can comment on or make changes to this bug.