Bug 257161 - OS Installation of RHEL4.5 fails on X6250 Blade servers.
OS Installation of RHEL4.5 fails on X6250 Blade servers.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.5
x86_64 Linux
medium Severity urgent
: ---
: ---
Assigned To: David Lehman
Alexander Todorov
:
: 187975 (view as bug list)
Depends On:
Blocks: 246627
  Show dependency treegraph
 
Reported: 2007-08-27 13:04 EDT by Sun Certifications
Modified: 2010-10-22 14:07 EDT (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2008-0653
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:05:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen snapshot (162.57 KB, application/vnd.oasis.opendocument.text)
2007-08-27 13:04 EDT, Sun Certifications
no flags Details
Scrren shot with more info (291.85 KB, application/octet-stream)
2007-08-27 16:04 EDT, Sun Certifications
no flags Details
anaconda dump (664.18 KB, text/plain)
2007-09-05 14:43 EDT, James G. Brown III
no flags Details

  None (edit)
Description Sun Certifications 2007-08-27 13:04:24 EDT
Description of problem:
OS Installation of RHEL4.5 fails on X6250 Blade servers.

Version-Release number of selected component (if applicable):
4.5

How reproducible:
100%

Steps to Reproduce:
1.Install RHEl4.5 on X6250 Server
2. At the end of installation it will fail with message File /usr/bin/anaconda,
line 1186, in intf.run(id, dispatch, donfigFile,Data)
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Sun Certifications 2007-08-27 13:04:24 EDT
Created attachment 174021 [details]
Screen snapshot
Comment 2 Chris Lumens 2007-08-27 13:14:23 EDT
Please attach the complete exception message to this bug report.  You've only
attached the top part, which is unfortunately the least specific part and
doesn't really convey any useful information about what's going wrong.
Comment 3 Sun Certifications 2007-08-27 16:04:57 EDT
Created attachment 174281 [details]
Scrren shot with more info
Comment 4 David Cantrell 2007-08-27 16:13:31 EDT
http://fedoraproject.org/wiki/AnacondaBugReporting

It's also not necessary to embed images in an OpenOffice document.  You can
attach JPEG or PNG graphics directly to the Bugzilla report.
Comment 5 Chris Lumens 2007-08-28 10:18:18 EDT
Could we please get the *complete* exception message?  What we've received is
still just a little piece of it.
Comment 6 Issue Tracker 2007-08-29 17:30:02 EDT
Here is all the information I could gather from serial console. Included 
is debugger help output, which doe snot tell options to save.
 +-------------+ Exception Occurred +-------------+
               |                                                |
               | An unhandled exception has occurred.  This   # |
 | is most likely a bug.  Please copy the       # |
               | full text of this exception and file a       # |
               | detailed bug report against anaconda at      # |
               | http://bugzilla.redhat.com/bugzilla/         # |
               |                                              # |
               | Traceback (most recent call last):           # |
               |   File "/usr/bin/anaconda", line 1186, in ?  # |
               |     intf.run(id, dispatch, configFileData)   # |
               |   File                                       # |
               | "/var/tmp/anaconda-10.1.1.63//usr/lib/anaco  # |
               | nda/text.py", line 511, in run               # |
               |                                                |
               |        +----+                +-------+         |
               |        | OK |                | Debug |         |
               |        +----+                +-------+         |
               |                                                |
               |                                                |
               +------------------------------------------------+

 dispatch.gotoNext()                      # |
               |   File                                       # |
               | "/var/tmp/anaconda-10.1.1.63//usr/lib/anaco  # |
               | nda/dispatch.py", line 171, in gotoNext      # |
               |     self.moveStep()                          # |
               |   File                                       # |
               | "/var/tmp/anaconda-10.1.1.63//usr/lib/anaco  # |
               | nda/dispatch.py", line 239, in moveStep      # |
               |     rc = apply(func, self.bindArgs(args))    # |
               |   File                                       # |
               | "/var/tmp/anaconda-10.1.1.63//usr/lib/anaco  # |
 nda/packages.py", line 570, in               # |
               | turnOnFilesystems                            # |
               |     thefsset.createLogicalVolumes(instPath)  # |
               |   File                                       # |
               | "/var/tmp/anaconda-10.1.1.63//usr/lib/anaco  # |
               | nda/fsset.py", line 1549, in                 # |
               | createLogicalVolumes                         # |
               |     entry.device.setupDevice(chroot)         # |
               |   File                                       # |
               | "/var/tmp/anaconda-10.1.1.63//usr/lib/anaco  # |
               | nda/fsset.py", line 2130, in setupDevice     # |
               |     raise SystemError, "vgcreate failed    for %s" 
%(self.name,)                        # |
               | SystemError: vgcreate failed for vg0         # |
               |
2. Clicked Debug
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1186, in ?
    intf.run(id, dispatch, configFileData)
  File "/var/tmp/anaconda-10.1.1.63//usr/lib/anaconda/text.py", line 
511, in run    dispatch.gotoNext()
  File "/var/tmp/anaconda-10.1.1.63//usr/lib/anaconda/dispatch.py", line

171, in gotoNext
    self.moveStep()
  File "/var/tmp/anaconda-10.1.1.63//usr/lib/anaconda/dispatch.py", line

239, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/var/tmp/anaconda-10.1.1.63//usr/lib/anaconda/packages.py", line

570, in turnOnFilesystems
    thefsset.createLogicalVolumes(instPath)
  File "/var/tmp/anaconda-10.1.1.63//usr/lib/anaconda/fsset.py", line 
1549, in createLogicalVolumes
    entry.device.setupDevice(chroot)
  File "/var/tmp/anaconda-10.1.1.63//usr/lib/anaconda/fsset.py", line 
2130, in setupDevice
    raise SystemError, "vgcreate failed for %s" %(self.name,)
SystemError: vgcreate failed for vg0

 >
/var/tmp/anaconda-10.1.1.63/usr/lib/anaconda/fsset.py(2130)setupDevice()
-> raise SystemError, "vgcreate failed for %s" %(self.name,)
(Pdb)

(Pdb) help

Documented commands (type help <topic>):
========================================
EOF    break  condition  disable  help    list  q       step     w
a      bt     cont       down     ignore  n     quit    tbreak   whatis
alias  c      continue   enable   j       next  r       u        where
args   cl     d          exit     jump    p     return  unalias
b      clear  debug      h        l       pp    s       up

Miscellaneous help topics:
==========================
exec  pdb

Undocumented commands:
======================
retval  rv

(Pdb)




Red Hat Issue Tracker wrote:
> Update to issue 130575 by Gyanesh.Sharma
> Action: 
>   
>> 3.  When the issue fails, click the debug button and there should be an
option to save to file.  Do that.
>>   
>>     
> I reproduced the issue but there is no option to save it to a file. I 
> tried help but all those are debugger commands. I am trying the serial 
> console option.
>   
>> 4.  Switch to a different virtual terminal (ctrl-alt-F1,F2,F3) and use
scp to copy the to another machine on the network.
>>
>> Thanks
>> Jeremy West
>>
>>
>> Status set to: Waiting on Client
>>
>>
>> https://enterprise.redhat.com/issue-tracker/130575
>>
>> Previous Events:
>> ----------------
>> Posted 08-28-2007 12:55pm by jwest
>> Gyanesh,
>>
>> I'm not overly familiar with the debugger myself.  I plan on getting
this issues reproduced in our lab this afternoon.  I'll let you know my
results.
>>
>> Thanks
>> Jeremy West
>>
>>
>>
>> Posted 08-28-2007 11:01am by Gyanesh.Sharma
>> I could not save the ouput,I can only take snapshot at this point. I do

>> not know if the problem will reproduce with serial setting. If there is

>> a way to get more info from the debugger then please let me know.
>>
>> thanks
>> Gyanesh
>> Red Hat Issue Tracker wrote:
>>   
>>     
>>> Update to issue 130575 by jwest
>>> Action: Gyanesh,
>>>
>>> Is it possible to get a more complete error message?  Can you save the
ilom output, or is it possible to use a serial console to capture the
output?
>>>
>>> Thanks
>>> Jeremy West
>>>
>>>
>>>
>>> https://enterprise.redhat.com/issue-tracker/130575
>>>
>>> Previous Events:
>>> ----------------
>>> Posted 08-28-2007 10:18am by bugzilla
>>> These changes made by clumens@redhat.com.
>>> Bugzilla comment added:
>>>  Could we please get the *complete* exception message?  What we've
received is
>>> still just a little piece of it.
>>>
>>>
>>> https://bugzilla.redhat.com/show_bug.cgi?id=257161
>>>
>>>
>>> Posted 08-28-2007 10:08am by jwest
>>> Gyanesh,
>>>
>>> Do you have access to the 4.6 beta that just went out yesterday?  If
so, can you confirm if this has been resolved in that release?
>>>
>>> Thank you
>>> Jeremy
>>>
>>>
>>> Status set to: Waiting on Client
>>>
>>>
>>>
>>>   
>>>     
>>>       
>>
>>
>>
>>   
>>     
>
>
>
> Status set to: Waiting on Tech
>
>
> https://enterprise.redhat.com/issue-tracker/130575
>
> Previous Events:
> ----------------
> Posted 08-28-2007 01:03pm by jwest
> Gyanesh,
>
> Here are the steps I would use to save this debugging output.  While
I'm working on my installation, feel free to try these.
>
> 1.  Perform a network install (pxe should work)
> 2.  Reproduce the issue
> 3.  When the issue fails, click the debug button and there should be an
option to save to file.  Do that.
> 4.  Switch to a different virtual terminal (ctrl-alt-F1,F2,F3) and use
scp to copy the to another machine on the network.
>
> Thanks
> Jeremy West
>
>
> Status set to: Waiting on Client
>
>
> Posted 08-28-2007 12:55pm by jwest
> Gyanesh,
>
> I'm not overly familiar with the debugger myself.  I plan on getting
this issues reproduced in our lab this afternoon.  I'll let you know my
results.
>
> Thanks
> Jeremy West
>
>
>
>
>   




This event sent from IssueTracker by jwest 
 issue 130575
Comment 7 James G. Brown III 2007-09-05 14:43:47 EDT
Created attachment 187891 [details]
anaconda dump

issue reproduced and resulting anacdump.txt
Comment 9 Jeremy West 2007-09-06 14:57:56 EDT
ENG,

The customer hasn't been able to get an anaconda dump to us yet, however James
Brown has been able to reproduce the issue and has attached the dump file.  Will
this work?

Thanks
Jeremy West
Comment 10 RHEL Product and Program Management 2007-09-17 04:54:33 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 24 David Lehman 2008-04-14 19:44:13 EDT
Fix will be in anaconda-10.1.1.84-1.
Comment 28 Andrew Hecox 2008-06-10 15:34:01 EDT
*** Bug 187975 has been marked as a duplicate of this bug. ***
Comment 30 errata-xmlrpc 2008-07-24 15:05:52 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0653.html

Note You need to log in before you can comment on or make changes to this bug.