Bug 25717 - Installer does not detect and install proper module for pcmcia
Installer does not detect and install proper module for pcmcia
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
David Lawrence
Florence Gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-02 09:16 EST by mattias pettersson
Modified: 2007-04-18 12:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-28 21:54:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description mattias pettersson 2001-02-02 09:16:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


Using Dell Inspiron 5000e with a Xircom_tulip_cb and when installing it 
does not load this module. When trying to load it after installing the 
module does not work...

Reproducible: Always
Steps to Reproduce:
Reinstalled Fisher with the same result.	

Actual Results:  eth0 doesn't work

Expected Results:  eth0 does work

cant produce this due to the fact that I cant connect to network from 
within Fisher...
Comment 1 mattias pettersson 2001-02-02 11:02:03 EST
Errormessage when booting:
symbol for parameter reverse_probe not found
Comment 2 Glen Foster 2001-02-02 17:14:03 EST
Changing component to anaconda
Comment 3 Glen Foster 2001-02-02 18:08:50 EST
We (Red Hat) should really fix this before the next release.
Comment 4 mattias pettersson 2001-02-03 14:30:02 EST
It's not really anacondas fault though, after looking around I've found that 
it's really a kernel related problem. When switching to 2.4.0 tulip_cb has been 
renamed to xircom_tulip_cb and probably got extended functionality. This gets 
the same if I deinstall networking and reinstall it manually. But the module 
isn't listed in linuxconf either.. tulip is but not xircom_tulip_cb. I'm 
keeping fisher installed if you need additional info.
Comment 5 Erik Troan 2001-02-06 12:29:25 EST
What kind of pcmcia card do you have? Can you run 'cardctl ident'?
Comment 6 mattias pettersson 2001-02-06 13:34:15 EST
cardctl ident gives me:
"Xircom", "Cardbus Ethernet 10/100+Modem 56", "CBEM56G", "1.03"
Comment 7 Erik Troan 2001-02-07 19:25:37 EST
Are you sure we don't try and install this module? What module is pcmcia looking
for? Does /etc/pcmcia/config look right for this card?
Comment 8 mattias pettersson 2001-02-08 03:27:16 EST
Yes, you install it, but it doesn't work... It, as I've stated earlier,
tries to enable the module when booting but exits with:
"symbol for parameter reverse_probe not found"

Will return with /etc/pcmcia/config look after reboot.. ;)
Comment 9 mattias pettersson 2001-02-08 05:02:13 EST
When I booted to look in /etc/pcmcia/config I also tried running netconf and
stripping the eth0 section of it down to only DHCP and module xircom_tulip_cb
I then restarted network and tried the solution to another bug 'ifconfig eth0
arp' and see and behold, I'm online using fisher...

However, this is not a working solution for newbies to the system. So even if
the bug is "solved" it really isn't because a user needs to hack around to much
to get it working.

Comment 10 Erik Troan 2001-02-22 15:47:40 EST
xircom tulip is just hosed
Comment 11 Michael K. Johnson 2001-02-28 21:54:49 EST
When 2.4.2-0.1.16 or later shows up in rawhide, please try it.  It
fixes all our known xircom cardbus problems.

Note You need to log in before you can comment on or make changes to this bug.