Bug 25724 - Package/CD read problem forces restart of update
Package/CD read problem forces restart of update
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-02 10:46 EST by Gil Chilton
Modified: 2007-04-18 12:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-13 00:14:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gil Chilton 2001-02-02 10:46:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)


During the upgrade to Fisher (+ extra manually selected files) from a 2 
day old RedHat 7.0 on a Dell laptop I got the following message on the 2nd 
disk:

"The file /mnt/source/RedHat/RPMS/kernel-doc-2.4.0-0.99.11.i386.rpm cannot 
be opened.  This is due to a missing file, a bad package, or bad media.  
Press <return> to try again"

When I pressed the OK button it returned to the same screen forever.  
There was no apparent way to proceed with the install and it did not 
appear to access the CD.  A 'skip this file' option would be nice on this 
screen.  I had to start over and chose a new install even though there was 
no apparent issue with the data on the CD.

After restarting, I was able to do an install from scratch that included 
the same rpm file without any problems.

Reproducible: Didn't try given the partial upgrade state - I did a fresh 
install
Steps to Reproduce:
1. Reach a condition where anaconda thinks that it cannot access an rpm 
file for installation
2. The error screen does not allow skipping the unavailable rpm and gets 
into an endless loop.
3. No apparent CD read attempts occurred during the endless loop.
Comment 1 Erik Troan 2001-02-02 14:21:49 EST
If you didn't pop the CD in and out, the buffer on the CDROM drive would prevent
the light from turning on on retries.

A "skip package" is a bad idea, as we don't know how important that package is.
It could likely leave you with an unbootable system.
Comment 2 Jesper Skov 2001-04-19 09:23:18 EDT
I'm reopening this bug - just to get your attention and have you reconsider
the issue. You can close it again for all I care. But:

I had a media failure on bdflush while updating my machine to 7.1. Stopping
an update midways through has much more potential to be fatal than skipping
a single package. I was _really_ annoyed with not having the option to
skip the package at the time.

Making policy decisions for Joe FirstTimeInstaller is fine. But I like to
think that I know a thing or two more than Joe - and I would have been much
happier skipping the package than rebooting my box in the middle of the upgrade,
particular given the package in question.

FWIW I could not eject the CD since it was mounted and the mount point
was active so I could not unmount it. I was plenty pissed, let me tell you.

Fortunately, the package was one of the first, so my system didn't get screwed.
But it could just as easily have been. All because I was given no other option
than that useless 'press here, and I'll pop up another dialog just like it'
-dialog.

Thanks,
Jesper
Comment 3 Stephen Adkins 2001-04-20 10:22:55 EDT
I get a similar message when installing on a laptop using the pcmcia.img boot 
disk and installing from an internal FTP site. It always says the 
file /mnt/sysimage/tmpindexhtml-7.1-2.noarch.rpm cannot be opened.
Comment 4 Need Real Name 2001-05-01 14:29:24 EDT
this happened me, exactly this, and my workaround to not start over 
the installation was to:

- switch to the console (alt-f2)
- umount /mnt/source
- mount -t iso9660 /dev/cdrom /mnt/source
- alt-f1 and voili, everything went smoothly

Note You need to log in before you can comment on or make changes to this bug.