This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 25738 - Machine reboots during nighttime standby. Related to apmd ?
Machine reboots during nighttime standby. Related to apmd ?
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-02 12:23 EST by Cristian Degli Esposti Boschi
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-05 04:51:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Cristian Degli Esposti Boschi 2001-02-02 12:23:56 EST
From Bugzilla Helper:

After an upgrade from RedHat 6.1 to RedHat 7.0 the system hangs or, more
frequently, reboots suddenly without any apparent reason.
During daytime I can launch several 'heavy' application at a time without too much problems but,
when I leave the machine at the login screen during the night (maybe with some background
processes of mine) every morning after I find it has been rebooted (or stopped).
The same happens to a colleague, after a clean installation of RedHat 7.0.
Could it be related to some deamons (apmd ??) which is activated after
long standbies?
Generically they're desktop PC's equipped with Athlon CPU, 256 Mb of RAM,
ethernet network card ... Need more info?

Thanks for your time.                            C.D.E.B.

Reproducible: Sometimes
Steps to Reproduce:
1. Exit from a regular session, possibly leaving some background program running.
2. Wait for the night leaving the PC on.
3. Find it rebooted or hang?
Comment 1 Bernhard Rosenkraenzer 2001-02-02 12:32:16 EST
Can't be apmd. Most likely flaky hardware, possibly a kernel bug.
Assigning to the kernel group.
Comment 2 Arjan van de Ven 2001-02-02 12:52:44 EST
Can be screensaver related. Do you and your colleague happen to have
the same brand of videocard ?
Comment 3 Cristian Degli Esposti Boschi 2001-02-07 05:17:24 EST
In fact, both the video cards should be of the ATI Mach family (8 Mb of video
RAM).
Screensavers seem to be the path to follow, even if sometimes the machine hangs
or reboots while I'm working...What should we try? What has changed in this
sense from RedHat 6.x to RedHat 7.0? Are there relevant upgrades to the
installation CD's? Thanx!

C.D.E.B.
Comment 4 Michael K. Johnson 2001-02-08 16:22:27 EST
Well, try turning off the screensavers first to make sure that they
are the problem before pursuing it any further.
Comment 5 Cristian Degli Esposti Boschi 2001-02-09 04:25:40 EST
Well, but how can I turn off the screensaver from
a login manager window (which in my case has
become that of GNOME after the upgrade)?

C.D.E.B.
Comment 6 Michael K. Johnson 2001-02-13 15:53:59 EST
GNOME control center.  It's the toolbox icon.
Comment 7 Cristian Degli Esposti Boschi 2001-02-21 03:51:55 EST
I'm now convinced that it's not directly related to screensavers.
I leave my session opened with screensaver disabled and the
machine hangs anyway. One time it hanged while I was doing
nothing but editing an e-mail ... Any suggestions?

Thanks, C.D.E.B.
Comment 8 Michael K. Johnson 2001-02-21 14:04:04 EST
Ugh.  We have similar machines here without seeing this problem at all.
It could even be the X server -- could you try shutting down X overnight
and see if the problem persists?
Comment 9 Cristian Degli Esposti Boschi 2001-03-08 07:14:26 EST
Darn ... I disabled all screensavers and quit from X during nighttime but
the problem persists and gets worse. This morning I found the machine
hanged. I restarted it and in one hour it stopped other two times, while
making simple things like editing a text or reading a message.
My colleague gave it up and passed to another distribution. Another one
told me it could be something related with crond (or maybe anacron)
which is periodically trying to perform a task which cannot be completed
due to some other problem (lack of directory or else). A partial confirm
could come from the fact that, initially, when I upgraded to RH7 at home
under root there came tons of fuzzy messages from crond. Any ideas?
Thanks again, C.D.E.B.
Comment 10 Cristian Degli Esposti Boschi 2001-05-05 04:51:36 EDT
Maybe is something related with AMD Athlon (700 MHz) processors.
However, better to give up...I passed to DEBIAN.
Thanks anyway,

C.D.E.B.
Comment 11 Mike A. Harris 2002-09-11 17:57:00 EDT
Closing bug WORKSFORME due to lack of ability to reproduce, and
reporter indication of changing distributions and no longer being
interested in troubleshooting/etc.

Note You need to log in before you can comment on or make changes to this bug.