Bug 2574 - Oracle and Relink is not working
Oracle and Relink is not working
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
6.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Cristian Gafton
:
: 2776 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-05 14:40 EDT by braccos
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-28 01:41:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description braccos 1999-05-05 14:40:44 EDT
I installed Oracle on the Red Hat 5.3. The server was
working. I migrate to Red Hat 6.0 and I re-installed also
the Oracle server same version (8.0.5).
I relink all the code, but when I launch all the
executables, I obtain a core dump due to a segmantation
fault. I think i depence from the libraries, nothis is
changed with Oracle, the only thing that is changed is the
kernel and I suppose something in the libraries that you
have changed, because I tryed also another test. Before to
relink I asked only to install the binaries, without to
relink, all the executables were working, after relink core
dump again.
I think there is a bug somewhere, I suppose in the
libraries because it was working on the 5.3
Let me know if it is possible to fix the problem, at the
moment I had to switch to another distribution, until you
don't fix this problem, I need Oracle in my office but it's
impossible to install it using red hat 6.0.
Let me know when you'll fix the problem.

Regards

stefano Bracco
UNIX System Manager at ITER JWS Garching
braccos@itereu.de
Comment 1 mjp 1999-05-12 11:23:59 EDT
Oracle8 does not work with glibc2.1, which Redhat 6.0 uses.  This is
actually Oracle's problem, not RedHat's (since they appeared to have
used incorrect practices regarding variables that were well documented
before O8's release for Linux).  At this point, you'd probably want to
use O8i anyway, which they should be shipping for Linux in May/June,
and I think will work with glibc2.1.  If you want to use O8 for now,
you should use RedHat 5.2, which works fine.  It isn't wise to upgrade
major servers (especially databases) just for the sake of upgrading,
and especially less than a week after the product has been released
and hasn't been kicked around yet.  I run Oracle8 on Redhat 5.2 sans
problem and don't plan to upgrade to 6.0 because there's really no
need to. If it ain't broken...
You should be addressing this issue in the Linux forum at:
http://technet.oracle.com/
although a number of people have already posted this, so it's just a
matter of waiting for a patch for O8, or forget O8 altogether and go
with O8i, assuming it actually works with glibc2.1.
Comment 2 Bill Nottingham 1999-05-13 10:17:59 EDT
*** Bug 2776 has been marked as a duplicate of this bug. ***

Oracle 8.0.5 will not install with Redhat 6.0.  It installs
great with 5.2.
I do not see a item above that I can pick to tell of such.
I picked aboot.  This does not mean there is a problem with
aboot.

Thanks,
Steven
Comment 3 Cristian Gafton 1999-07-28 01:41:59 EDT
The Makfiles for Oracle should be modified to use the compilers and
linkers provided as par of the compat-* packages. Oracle is trying to
link glibc-2.0 object files on a glibc-2.1 system and that will fail,
since only the shared libraries are guaranteed compatibility between
different compiler/libc combinations.

But using the compilers provided in the compat-* packages should do
the trick.

Note You need to log in before you can comment on or make changes to this bug.