Red Hat Bugzilla – Bug 257421
KiCad needs at least wxGTK-2.7.1
Last modified: 2007-11-30 17:12:14 EST
The KiCad lastest version (2007-07-09) needs at least wxGTK-2.7.1 and I should
want to package this release for FC-6.
So, I'll be happy if you agree to package a such release for FC-6.
Every updated release of wxGTK brings up new and exciting bugs in various
programs that use it. I'd really like to avoid going out of the 2.6.x series on
FC-6. However, Fedora 7 and newer have wxGTK 2.8.x, which sounds like it'll work
for what you need. I know it's nice to not neglect the older releases, but we
have to balance that with the possible downsides.
I understand the problem and respect your position.
Is wxGTK 2.8.x in FC-6 possible?
Do you have a try?
It might be possible.
But it is NOT recommended for FC-6 as it will break many packages which reply
on wxgtk. Not to say, many users will have yum dependencies errors.
If it break many packages, one should build compat-wxgtk-26 !
I suggest kicad to be updated on F-7 and onwards.