Bug 257421 - KiCad needs at least wxGTK-2.7.1
KiCad needs at least wxGTK-2.7.1
Product: Fedora
Classification: Fedora
Component: wxGTK (Show other bugs)
All All
high Severity urgent
: ---
: ---
Assigned To: Matthew Miller
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-08-27 14:40 EDT by Alain Portal
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-08-28 10:58:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Alain Portal 2007-08-27 14:40:43 EDT
The KiCad lastest version (2007-07-09) needs at least wxGTK-2.7.1 and I should 
want to package this release for FC-6.
So, I'll be happy if you agree to package a such release for FC-6.
Comment 1 Matthew Miller 2007-08-27 15:00:30 EDT
Every updated release of wxGTK brings up new and exciting bugs in various
programs that use it. I'd really like to avoid going out of the 2.6.x series on
FC-6. However, Fedora 7 and newer have wxGTK 2.8.x, which sounds like it'll work
for what you need. I know it's nice to not neglect the older releases, but we
have to balance that with the possible downsides.
Comment 2 Alain Portal 2007-08-29 07:02:17 EDT
I understand the problem and respect your position.
Is wxGTK 2.8.x in FC-6 possible?
Do you have a try?
Comment 3 Chitlesh GOORAH 2007-08-29 07:13:11 EDT
It might be possible.

But it is NOT recommended for FC-6 as it will break many packages which reply 
on wxgtk. Not to say, many users will have yum dependencies errors.

If it break many packages, one should build compat-wxgtk-26 !

I suggest kicad to be updated on F-7 and onwards.

Note You need to log in before you can comment on or make changes to this bug.