Bug 25755 - zlib-1.1.3-18 is bad
Summary: zlib-1.1.3-18 is bad
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: zlib   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Aaron Brown
URL:
Whiteboard: Florence RC-1
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-02 21:23 UTC by Red Hat Bugzilla
Modified: 2008-03-13 19:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-14 08:40:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Red Hat Bugzilla 2001-02-02 21:23:23 UTC
zlib-1.1.3-18 failed "make test" in zlib.
zlib-1.1.3-14 is ok. The problem is those
2 patches in zlib-1.1.3-18:

zlib-x86-opt-20010103C.diff
zlib-x86-opt-fix.diff

Comment 1 Red Hat Bugzilla 2001-02-02 22:06:22 UTC
Ben, this was caused by your optimizations... could you take a look at it?

Comment 2 Red Hat Bugzilla 2001-02-02 23:05:57 UTC
This defect is considered MUST-FIX for Florence Release-Candidate #1

Comment 3 Red Hat Bugzilla 2001-02-05 21:22:57 UTC
this is fixed in zlib-1.1.3-19

Comment 4 Red Hat Bugzilla 2001-02-08 21:07:01 UTC
zlib-1.1.3-19 still has a bug. But it is now much
harder to reproduce. You can give it a try. But
I cannot promise you can duplicate it easily.

1. Build anaconda with zlib 1.1.3-19.
2. Try harddrive install/upgrade.

When the loader loads modules from hdstg1.img
on harddrive, it will complain

* going to insmod eepro100.o (path is NULL)
error 2 reading header: cpio: Bad magic
.....

and then die. Interesting enough, loader has
no problems of loading modules from
netstg1.img. Using the old zlib, the problem
goes away.

Comment 5 Red Hat Bugzilla 2001-02-13 02:05:36 UTC
ARG revert this immediately. If you need to make any changes to zlib please let
the installer team know first so we can test it before it hits the tree.

Comment 6 Red Hat Bugzilla 2001-02-13 19:45:17 UTC
Can you test this again with zlib-1.1.3-21?  That should squash a thinko the
last one introduced.

Comment 7 Red Hat Bugzilla 2001-02-14 05:41:20 UTC
Mike, is this fixed with that version?  If so, please resolve.

Comment 8 Red Hat Bugzilla 2001-02-14 08:40:04 UTC
not resolved in zlib-1.1.3-21.

Comment 9 Red Hat Bugzilla 2001-02-15 01:26:56 UTC
zlib-1.1.3-22 reverts the patch.


Note You need to log in before you can comment on or make changes to this bug.