Bug 25815 - lpd.init mangles status messages, not translated.
lpd.init mangles status messages, not translated.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: LPRng (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
David Lawrence
Florence RC-1
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-02 20:49 EST by Need Real Name
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-06 11:42:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-02-02 20:49:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.0-0.99.11 i686)


As root, in the /etc/rc.d/init.d directory I type: ./lpd start and it says
"Starting lpd:" without a Ok or Failed message.  If I check the running
processes, lpd is not present. lpq reports lpd is not running. Rebooting
did not change anything.

Reproducible: Always
Steps to Reproduce:
1.As root, type /etc/rc.d/init.d/lpd start
2.
3.
	

Actual Results:  [root@bugeyes init.d]# ./lpd status
lpd is stopped
[root@bugeyes init.d]# ./lpd start
Starting lpd: [root@bugeyes init.d]# lpq
Printer 'missingprinter@localhost' - cannot open connection - Connection
refusedMake sure LPD server is running on the server

Expected Results:  Starting lpd:                [OK]
Comment 1 Glen Foster 2001-02-05 17:50:57 EST
We (Red Hat) should really try hard to fix this before next release.
Comment 2 Ian Macdonald 2001-02-05 19:50:35 EST
printtool-backend exits with a return code 1, which causes the script to exit.
This seems to be because the format for /etc/printcap has changed, requiring you
to run printtool-gui. However, even if you redefine your printer using the new
printtool, printing is still horribly broken. If you select a JetDirect printer,
the new printcap will try to point to a jetdirect filter that does not exist. If
you fix this by adding the correct path manually, printing still doesn't work.

Had to downgrade to RHL 7.0 versions of LPRng and printtool to obtain working
printing again.
Comment 3 Crutcher Dunnavant 2001-02-06 11:42:41 EST
The jetdirect issue is dealt with, I forgot to include the files in the rpm build.

lpd.init does not start lpd if there are no printers defined. (this is
considered a feature, and has been requested many times).

 The real issue here is that lpd.init isn't kosher at the moment, and doesn't
really tell you what's up. I am reworking the summary to reflect this.
Comment 4 Crutcher Dunnavant 2001-02-06 16:13:39 EST
fixed

Note You need to log in before you can comment on or make changes to this bug.