Bug 2582 - bad insmod of block device
Summary: bad insmod of block device
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.0
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
Depends On:
TreeView+ depends on / blocked
Reported: 1999-05-06 00:32 UTC by brent.seufert
Modified: 2017-12-12 19:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 1999-08-02 18:44:20 UTC

Attachments (Terms of Use)

Description brent.seufert 1999-05-06 00:32:52 UTC
tried on notebook pcmcia and pentium PC.  at the end of the
install over network using http both creating a boot disk
and writing lilo boot partition fails:  can't access hard

Looking at the install log terminal, it fails to insmod the
block device.  attempting to insmod the block device fails
due to different version of block module and kernel, after
the 2.2.5-??.  force insmod creates works with warning, but
the install still attempts insmod and fails.

Comment 1 brent.seufert 1999-05-11 22:23:59 UTC
OK, more details.  I tried the install with ftp from my own server.
when install tries to create boot disk OR write LILO boot block, we

* running: /bin/insmod /bin/insmod /modules/loop.o
* insmod failed!

when I attempt insmod by hand:

# /bin/insmod /modules/loop.o
/modules/loop.o: kernel-module version mismatch
    /modules/loop.o was compiled for kernel version 2.2.5-14BOOT
    while this kernel is version 2.2.5-4BOOT.


Comment 2 jmm 1999-05-13 12:56:59 UTC
I had the same sort of problem during a CD-ROM installation - it's not
just network boots.

One possibly related item in my case was that I skipped the network
interface device configuration (I hadn't checked what my network card
device type was and my guess failed).  If the loop.o driver is for
TCP/IP loopback, that would fit.

Being unable to "insmod loop.o" caused failure of both the attempt to
build a boot disk and the attempt to build LILO.  I got the same
version mismatch message when trying it by hand.  Looking around, I
also found a version 2.2.5-15 of loop.o, but that also gives a version
mismatch if I tried to insmod it.

Comment 3 David Lawrence 1999-07-01 20:27:59 UTC
Does this still occur with the latest boot images available from our
web site?


Comment 4 Jay Turner 1999-08-02 18:44:59 UTC
Closing bug doe to lack of activity.  Reopen if you are still
experiencing problem with the install.

Comment 5 nagel 1999-09-21 15:41:59 UTC
I've experienced this bug. I'm using the latest boot images
(09-Sept-1999) and installing using the CD-ROM. Tried the install and
it failed to make a boot disk and failed to install lilo. I also tried
the upgrade method and the installer seg faulted when trying to make
the boot disk.

Comment 6 openshift-github-bot 2017-12-12 19:37:50 UTC
Commit pushed to master at https://github.com/openshift/origin-web-console

Merge pull request #2583 from sg00dwin/modal-alert-issue2582

Automatic merge from submit-queue.

Enable word-break for <code> elements within alerts.

Fixes https://github.com/openshift/origin-web-console/issues/2582

`.word-break-all` required for Firefox and IE

Note You need to log in before you can comment on or make changes to this bug.