Bug 25849 - Xconfigurator encounters problem during test
Xconfigurator encounters problem during test
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
David Lawrence
Florence Gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-03 08:09 EST by Chris Runge
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-28 08:53:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-generated config file (3.04 KB, text/plain)
2001-02-03 08:10 EST, Chris Runge
no flags Details
Xconfigurator-generated config file (1.29 KB, text/plain)
2001-02-03 08:11 EST, Chris Runge
no flags Details

  None (edit)
Description Chris Runge 2001-02-03 08:09:33 EST
Beta 3 (Fisher)

During installation anaconda correctly detected my Voodoo 5 card (although
it detected the memory on board as being 16MB, which is incorrect). The
configuration file generated by this works.

Post-install, if I run Xconfigurator it always encounters problems during
the test phase. I've tried a number of different things and it always says
there was a problem.

There are two interesting things here:
(1) The config file that Xconfigurator generates after post-install does
work. startx brings up X just fine.
(2) The config file anaconda generates and the config file Xconfigurator
generates differ in a number of ways. I will try to attach the files.
Comment 1 Chris Runge 2001-02-03 08:10:25 EST
Created attachment 8840 [details]
anaconda-generated config file
Comment 2 Chris Runge 2001-02-03 08:11:13 EST
Created attachment 8841 [details]
Xconfigurator-generated config file
Comment 3 Glen Foster 2001-02-05 17:57:43 EST
This defect is considered MUST-FIX for Florence Release-Candidate #1
Comment 4 Preston Brown 2001-02-08 18:49:39 EST
what would REALLY help is if you can attach the /var/log/XFree86.9.log file
generated right after a failed run with Xconfigurator.
Comment 5 Preston Brown 2001-02-14 00:37:21 EST
The only difference between these two files is that you selected 16bpp with Xconfigurator, and 24bpp with anaconda.  It appears the Voodoo5 currently doesn't work in 16bpp, but we don't have hardware to verify this on.
Comment 6 Chris Runge 2001-02-15 11:33:25 EST
I only have the V5 card for a few more days so I tried to do some more testing
(FWIW this was with a reinstall since the problems occurred). Some things I
noticed:

- Xconfigurator worked fine... most of the time. I tried a few different res/bpp
combos and had no problems. Once or twice it would lock up the system, however.
More on why this might be later.
- Xconfigurator worked twice. The third time it segfaults and I can't run it
again until I reboot.
- gpm didn't work until I did "service gpm restart" once/twice. It appeared that
the lockups occurred if I got gpm started beforehand. If I didn't then
Xconfigurator worked fine (until the 3rd time).

Some more info about my setup:
- MS Intellimouse Explorer connected to USB port
- MS Force Feedback 2 connected to USB port

Checking /var/log/messages after some successful attempts showed problems with
NMI and gpm (see 27393). On a hunch I removed the joystick. After doing this:

- the mouse worked immediately upon reboot (no service gpm restart)
- no problems with Xconfigurator (at least so far)
- no Xconfigurator segfaults after running multiple times

I realize all of this is something of a jumble. I don't know exactly what the
problem is except that I appear to have a number of problems when the MS
joystick is plugged in. I don't expect to be able to use it under Linux (it is a
dual boot system), but it would be nice to be able to handle the stick being
plugged in.
Comment 7 Chris Runge 2001-02-28 08:53:21 EST
unfortunately I don't have the V5 card any longer so I can no longer test this
issue or confirm a resolution
Comment 8 Bill Nottingham 2001-03-01 00:57:27 EST
OK, I'm going to close this as it appears Xconfigurator works OK; it's just
running into the joystick problems mentioned in the other bug(s).

Note You need to log in before you can comment on or make changes to this bug.