Bug 258541 - Anacron reports run-parts error
Anacron reports run-parts error
Status: CLOSED DUPLICATE of bug 254220
Product: Fedora
Classification: Fedora
Component: crontabs (Show other bugs)
8
All Linux
medium Severity low
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-27 20:06 EDT by Carl Preddy
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-28 02:59:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl Preddy 2007-08-27 20:06:09 EDT
Description of problem:
anacron-2.3-53.fc8 mails an error message every night that concludes with 

/usr/bin/run-parts: line 5: [: ==: unary operator expected

Version-Release number of selected component (if applicable):
F8test1 for x86_64

How reproducible: like clockwork

Steps to Reproduce: none; seems to be installed this way 
Actual results: error email from anacron to root 
Expected results: not that 

Additional info:
Line 5 of /usr/bin/run-parts reads
[ $AUX1 == $AUX2 ] || exit 0
I believe the intended construct should be 
[ $AUX1 == $AUX2 ] && exit 0
Comment 1 Marcela Mašláňová 2007-08-28 02:59:39 EDT
Correct is [ "$AUX1" == $AUX2 ] || exit 0
That means if they are not the same, then don't run anything.

*** This bug has been marked as a duplicate of 254220 ***

Note You need to log in before you can comment on or make changes to this bug.