Bug 258561 - Creating multiple snapshots causes kernel panic
Creating multiple snapshots causes kernel panic
Status: CLOSED DUPLICATE of bug 211525
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2 (Show other bugs)
5.0
x86_64 All
medium Severity medium
: ---
: ---
Assigned To: Milan Broz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-27 20:09 EDT by Christian Nygaard
Modified: 2013-02-28 23:05 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-07 09:43:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Nygaard 2007-08-27 20:09:54 EDT
Description of problem:
If you create multiple snapshots with LVM and then use lvremove
the kernel panics. This also happens if you lvcreate, do not use lvremove
and just reboot, then the system always panics.

Version-Release number of selected component (if applicable):
5

How reproducible:
Create multiple lvm snapshots and then remove them, when you remove
the last snapshot the kernel panics.

Steps to Reproduce:
1. i=0 ; while [ $i -lt 18 ] ; do lvcreate -L32M -s -n test$i /dev/system/var ;
let i=i+1 ; done

2. i=0 ; while [ $i -lt 18 ] ; do lvremove -f /dev/system/test$i ; let i=i+1 ; done

3.
  
Actual results:
Kernel Panic

Expected results:
Snapshots

Additional info:
Comment 1 Milan Broz 2007-09-07 09:43:35 EDT
There is no syslog attached output but I am almost sure that this is duplicate
of bug 211525.
If it is different problem, please reopen the bug and attach syslog with OOps
information, thanks.


*** This bug has been marked as a duplicate of 211525 ***

Note You need to log in before you can comment on or make changes to this bug.