Bug 2589 - PCMCIA probe fails for Dell Inspiron
PCMCIA probe fails for Dell Inspiron
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-06 02:54 EDT by shing
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-15 18:18:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shing 1999-05-06 02:54:51 EDT
The PCMCIA probe routine does not recognize the TI1131
controller on the Dell Inspiron 3000. This can be fixed in
pcmcia-probe.c with the following patch:

--- misc/src/install/pcmcia-probing/pcmcia-probe.c.orig Sat
Nov  7 10:02:40 1998
+++ misc/src/install/pcmcia-probing/pcmcia-probe.c      Sat
Nov  7 10:03:08 1998
@@ -49,7 +49,7 @@
     { "Vendor id=1180. Device id=466.", "Ricoh RL5C466" },
     { "Vendor id=10b3. Device id=b106.", "SMC 34C90" },
     { "Vendor id=1013. Device id=1110.", "Cirrus PD6832" },
-    { "Vendor id=104c. Device id=ac12.", "TI 1131" }
+    { "Texas Instruments PCI1131", "TI 1131" }
 };
 #define PCI_COUNT (sizeof(pci_id)/sizeof(pci_id_t))


One question though: why wasn't the entire pcmcia-probe
routine (from the pcmcia package) included in the install
program, instead of just a small portion of it which is
currently the case?
Comment 1 David Lawrence 1999-05-06 14:23:59 EDT
This has been assigned to a developer for further review.
Comment 2 Bill Nottingham 1999-07-15 15:05:59 EDT
*** Bug 3434 has been marked as a duplicate of this bug. ***

Redhat-6.0 fails to detect pcmcia on a thinkpad 310E laptop,
so installing/upgrading is impossible. Even in expert mode,
there is no way to force loading of the pcmcia modules.

linux/pcmcia-cs has no trouble detecting the pcmcia slots,
so it must be a flaw in the red hat installer.

Non-redhat can be installed with no problem:
# cat /proc/pci
  Bus  0, device   4, function  0:
    CardBus bridge: Texas Instruments PCI1131 (rev 1).
      Medium devsel.  Master Capable.  Latency=32.  Min
Gnt=192.Max Lat=7.



------- Additional Comments From dkl@redhat.com  07/07/99 17:35 -------
Does the installer still fail to detect the pcmcia bridge if you have
Cardbus support disabled?

You can disable it by going into the BIOS (hitting F2 while turning on
the machine) and then go to System Security, disable CardBus support
then back out with the ESC key til you are asked to save the new
settings.
Comment 3 Bill Nottingham 1999-07-15 18:18:59 EDT
this should be fixed in the next installer release.

Note You need to log in before you can comment on or make changes to this bug.