Bug 25893 - tripwire --update failing
tripwire --update failing
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: tripwire (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-03 15:55 EST by mcisar
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-21 20:46:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mcisar 2001-02-03 15:55:08 EST
Have activated tripwire on several servers now, all are generating their 
reports daily as expected but on all servers when I try to issue a 
tripwire --update or tripwire --update -a  to update the database they 
fail with the following message.

[root@testserv report]# /usr/sbin/tripwire --update -a
### Error: File could not be opened.
### Filename: /var/lib/tripwire/report/testserv.iul.net-20010203-125754.twr
### No such file or directory
### Exiting...

The filename mentioned in the error always differs from any of the report 
files which are in the /var/lib/tripwire/report directory (insofar as the 
portion of the filename which in the example above is 125754).
Comment 1 Nalin Dahyabhai 2001-02-06 14:07:12 EST
The report filename is generated using the date and time when it was created. 
Do you have a similarly named file there, or is it just completely wrong?
Comment 2 mcisar 2001-02-06 16:23:49 EST
Yes, that directory contains a whole pile of reports... one every day (as 
generated by the daily cron job).  In the case of the example above I ran a 
report manually with tripwire --check immediately prior to running the 
tripwire --update I mention above... the report file it generated and which is 
in the directory was testsrv.iul.net-20010203-124037.twr
Comment 3 Need Real Name 2001-02-08 10:58:43 EST
It looks like the RH version of tripwire was coded to use the current date 
instead of the date of the last report:

# date;tripwire --update
Thu Feb  8 08:55:25 CST 2001
### Error: File could not be opened.
### Filename: /var/lib/tripwire/report/workstation-20010208-085525.twr
### No such file or directory
### Exiting...

Notice, the seconds exactly matches the date, I do have a whole slew of 
tripwire reports, last one dated 085101.  When I manually specify the last 
report with: 
tripwire --update -r /var/lib/tripwire/report/workstation-20010208-085101.twr

etc., all works.
Comment 4 Mike A. Harris 2002-08-08 02:57:50 EDT
Deferring for future investigation.
Comment 5 John Thacker 2006-04-21 20:46:39 EDT
Since tripwire hasn't been shipped in so long, and these versions aren't
supported, so I'm closing the bugs.

Note You need to log in before you can comment on or make changes to this bug.