Bug 259021 - Yum downloading rpms for wrong architecture
Yum downloading rpms for wrong architecture
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
8
i686 All
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-28 00:31 EDT by Dhaval Giani
Modified: 2014-01-21 17:59 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 10:37:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dhaval Giani 2007-08-28 00:31:38 EDT
Description of problem:
Yum is downloading rpms for the wrong architecture (i586 vs i686/i386)

Version-Release number of selected component (if applicable):


How reproducible:
Reproducable everytime. Started only a week or so back.

Steps to Reproduce:
1. Add livna repository
2. yum install madwifi
3.
  
Actual results:
Resolving Dependencies
--> Running transaction check
---> Package madwifi.i386 0:0.9.3.1-1.lvn7 set to be updated
--> Processing Dependency: madwifi-kmod >= 0.9.3.1 for package: madwifi
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package madwifi.i386 0:0.9.3.1-1.lvn7 set to be updated
---> Package kmod-madwifi.i586 0:0.9.3.1-2.2.6.22.4_65.fc7 set to be updated
--> Processing Dependency: kernel-i586 = 2.6.22.4-65.fc7 for package: kmod-madwifi
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package kmod-madwifi.i586 0:0.9.3.1-2.2.6.22.4_65.fc7 set to be updated
---> Package kernel.i586 0:2.6.22.4-65.fc7 set to be updated
--> Running transaction check
---> Package madwifi.i386 0:0.9.3.1-1.lvn7 set to be updated
---> Package kmod-madwifi.i586 0:0.9.3.1-2.2.6.22.4_65.fc7 set to be installed
---> Package kernel.i586 0:2.6.22.4-65.fc7 set to be installed
---> Package kernel.i686 0:2.6.22.4-65.fc7 set to be erased

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 madwifi                 i386       0.9.3.1-1.lvn7   livna             216 k
Removing:
 kernel                  i686       2.6.22.4-65.fc7  installed          47 M
Installing for dependencies:
 kernel                  i586       2.6.22.4-65.fc7  updates            15 M
 kmod-madwifi            i586       0.9.3.1-2.2.6.22.4_65.fc7  livna           
 255 k


Expected results:

Download the module for i686 and install that. (This anyway fails because of
conflicts)

Additional info:

This problem has started just a few days back. I'd downloaded the last version
of the madwifi driver and it had worked properly. I am not sure what has caused
it. Anything you want me try, let me know an I will get back to you ASAP.
Comment 1 Dhaval Giani 2007-08-28 01:28:25 EDT
small correction. The actual results case fails because of conflicts (i686
kernel conflicts with the i586 kernel). The expected result should be that the
i686 module should be downloaded and installed.
Comment 2 Jeremy Katz 2007-09-13 15:11:20 EDT
What is in /etc/rpm/platform?
Comment 3 Dhaval Giani 2007-09-13 23:28:17 EDT
[dhaval@gondor ~]$ cat /etc/rpm/platform 
i686-redhat-linux
[dhaval@gondor ~]$
Comment 4 Seth Vidal 2007-09-14 02:25:23 EDT
Could you also provide:
 yum list installed kernel

Comment 5 Dhaval Giani 2007-09-14 02:48:53 EDT
[dhaval@gondor ~]$ yum list installed kernel
Installed Packages
kernel.i686                              2.6.22.5-76.fc7        installed       
kernel.i686                              2.6.22.4-65.fc7        installed       
[dhaval@gondor ~]$ 
Comment 6 Stephen Warren 2007-11-10 00:48:17 EST
I assume that I'm having the same issue. I did a fairly standard F8 install,
this this:

yum install kernel-devel

I ended up with this:

rpm -q --queryformat %-{name}-%{version}-%{release}-%{arch}"\n" \
   kernel kernel-devel
kernel-2.6.23.1-42.fc8-i586
kernel-devel-2.6.23.1-42.fc8-i686

[swarren@esk ~]$ cat /etc/rpm/platform 
i686-redhat-linux

So now, /lib/modules/`uname -r`/build points at a non-existent directory.
Comment 7 Dhaval Giani 2007-12-05 07:23:15 EST
[root@gondor ~]# yum install xorg-x11-drv-fglrx
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package xorg-x11-drv-fglrx.i386 0:8.42.3-7.lvn8.1 set to be updated
--> Processing Dependency: fglrx-kmod >= 8.42.3 for package: xorg-x11-drv-fglrx
--> Processing Dependency: fglrx-kmod >= 8.42.3 for package: xorg-x11-drv-fglrx
--> Running transaction check
---> Package kmod-fglrx-2.6.23.1-42.fc8.i586 0:8.42.3-7.lvn8 set to be updated
--> Processing Dependency: kernel-i586 = 2.6.23.1-42.fc8 for package:
kmod-fglrx-2.6.23.1-42.fc8
--> Running transaction check
---> Package kernel.i586 0:2.6.23.1-42.fc8 set to be updated
--> Finished Dependency Resolution
--> Running transaction check
---> Package kernel.i586 0:2.6.23.1-42.fc8 set to be installed
---> Package xorg-x11-drv-fglrx.i386 0:8.42.3-7.lvn8.1 set to be updated
---> Package kernel.i686 0:2.6.23.1-42.fc8 set to be erased
---> Package kmod-fglrx-2.6.23.1-42.fc8.i586 0:8.42.3-7.lvn8 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Removing:
 kernel                  i686       2.6.23.1-42.fc8  installed          45 M
Installing for dependencies:
 kernel                  i586       2.6.23.1-42.fc8  fedora             16 M
 kmod-fglrx-2.6.23.1-42.fc8  i586       8.42.3-7.lvn8    livna             539 k
 xorg-x11-drv-fglrx      i386       8.42.3-7.lvn8.1  livna              13 M

Transaction Summary
=============================================================================
Install      3 Package(s)         
Update       0 Package(s)         
Remove       1 Package(s)         

Total download size: 29 M
Is this ok [y/N]: n
Exiting on user Command
Complete!
[root@gondor ~]# 


This I just got on F8. So it still exists.
Comment 8 Seth Vidal 2007-12-05 08:33:02 EST
Can you test yum 3.2.8-1 that's in updates-testing right now? I think it might
have the desired result.

thanks
Comment 9 Dhaval Giani 2007-12-05 09:28:53 EST
tested with yum 3.2.8-1. Same results
Comment 10 Seth Vidal 2007-12-05 09:53:35 EST
and once again:
yum list installed kernel\*

just to be sure your system hasn't been polluted already.
Comment 11 Dhaval Giani 2007-12-05 09:57:40 EST
[dhaval@gondor ~]$ yum list installed kernel\*
Installed Packages
kernel.i686                              2.6.23.1-42.fc8        installed       
kernel.i686                              2.6.23.1-49.fc8        installed       
kernel-debug.i686                        2.6.23.1-42.fc8        installed       
kernel-debug.i686                        2.6.23.1-49.fc8        installed       
kernel-debug-devel.i686                  2.6.23.1-49.fc8        installed       
kernel-debug-devel.i686                  2.6.23.1-42.fc8        installed       
kernel-devel.i686                        2.6.23.1-42.fc8        installed       
kernel-devel.i686                        2.6.23.1-49.fc8        installed       
kernel-headers.i386                      2.6.23.1-49.fc8        installed       
[dhaval@gondor ~]$ 

Comment 12 tony 2007-12-13 09:34:15 EST
I think I had a similar problem.

After the installation of Fedora 8 all the kernel updates were for i586 but my
machine is i686. I didn't check which kernel arch was originally installed, but
I assume it was i586 as /etc/yum.conf have exactarch=1. That wrong kernel arch
choosing gave me a lot of problems installing (non prebuild, but compiled)
kernel modules (nvidia, vmware) because the modules could not be loaded. Until
yesterday thanks to giving up and trying to install prebuild nvidia modules from
livna I realized I had the wrong kernel arch installed.

Tell me if this is the same bug or if I must fill a new bug entry.
Comment 13 Seth Vidal 2008-03-12 10:37:02 EDT
okay, I think we solved this when we moved a bunch of code out of yum-cli for
the code in yum/__init__.py

Could either of you test the above cases with yum 3.2.12 from rawhide?

I believe we've fixed this. If not, please reopen.

thanks

Comment 14 Stephen Warren 2008-03-16 13:56:42 EDT
I tried to test the new yum, but wanted to reproduce the original problem first,
to make sure I was actually testing it.

However, even yum-3.2.8.2.fc8.noarch is working correctly for me right now.

Is it still worth me testing this new yum, to confirm it still works?
Comment 15 Seth Vidal 2008-03-16 22:53:08 EDT
Yes, either way it is worth a shot.

Note You need to log in before you can comment on or make changes to this bug.