Bug 259161 - suspected miscompilation of sqlite breaks monotone on ppc
suspected miscompilation of sqlite breaks monotone on ppc
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: monotone (Show other bugs)
7
All All
medium Severity low
: ---
: ---
Assigned To: Roland McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F-ExcludeArch-ppc FE-ExcludeArch-ppc64
  Show dependency treegraph
 
Reported: 2007-08-28 03:34 EDT by Roland McGrath
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-28 01:13:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Roland McGrath 2007-08-28 03:34:23 EDT
Starting with monotone-0.36, the monotone test suite fails in "make check" only
on ppc and ppc64.  Upstream reports it works on other powerpc platforms/distros.

See http://koji.fedoraproject.org/koji/taskinfo?taskID=98891 for a build log
with the failure.  Rebuilding any monotone-0.36 rpm, or hand-building from
upstream sources, will show failures in "make check" on ppc/ppc64 under Fedora
[678], which all have the same compiler.

The suspected issue is a miscompilation of some C++ code in the sqlite sources
included in the monotone build.  There was a similar problem seen using gcc 4.2
and worked around, see
http://www.nabble.com/sqlite-fix-for-gcc-4.2.x-bug..-t4198798.html and
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=32575 about that.  The code that is
failing now has the workaround shown in that link already.  Without that
workaround, the Fedora gcc does produce code that gets even more errors in
monotone's test suite, though our gcc is 4.1.x-based and not 4.2.  But even with
it, something goes wrong inside sqlite and so we suspect a similar
miscompilation issue.

Since this only arises on ppc and ppc64 and I don't know how to work around it,
for the time being I'm building a new monotone with ExcludeArch: ppc ppc64.
Comment 1 Roland McGrath 2007-10-28 01:13:11 EDT
Seems to have disappeared in 0.37 or with newer compilers or something.

Note You need to log in before you can comment on or make changes to this bug.