Bug 2592 - users can not make pppd work
users can not make pppd work
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
6.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-06 03:44 EDT by gissi
Modified: 2015-01-07 18:37 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-08 12:08:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gissi 1999-05-06 03:44:21 EDT
I installed rh6.0 with kde (without gnome)

I tried to make kppp work:
1) if I login as root it says that pppd is not SUID enabled.
I enabled the SUID of the pppd and it worked
2) if I login as a user it says it can not access the modem
and that it can't write the ppp log.
I changed the permission of the ttySx and it could access
the modem. But it could not write the log and it did not
work!

I think it is important to fix it as many end-users will use
the ppp-connection!

Thank for your work, that I appreciate.
Comment 1 genec 1999-05-08 09:51:59 EDT
I also experienced these problems (sort of) -- I have both gnome and
kde installed.  As a user, I get the suid message but I did not see
this if I started kppp as root.  However, when as root, I start kppp
and try to connect nothing really happens (seems to not find the
modem).  I can get the modem to respond using minicom or the redhat
(control-panel) network configuration "activate" function.

Since there is no gnome "user friendly" ppp interface, kppp is needed!

Gene
Comment 2 genec 1999-05-08 21:23:59 EDT
More inforamtion --

1. I verified the root/non-root situation with respect to the suid
problem/message -- it is NOT issued if you invoke kppp when on as
root.

2. I install kdenetwork-1.1.1 (final) as distributed from ftp.kde.org.
The modem problem is fixed -- I can now (only as root) bring up kppp
and successfully connect to an ISP.

3.  It appears that the kde rpms are built on a pre-release "snapshot"
of kde -- with the "final" release of 1.1.1, I suggest that redhat
provide updates (on updates.redhat.com) for the set of kde rpms.

Gene
Comment 3 genec 1999-05-09 16:58:59 EDT
yet more comments:

1. It appears that kppp is installed WITHOUT the SUID set.

2. It appears that /dev/ttyS0-4 have the wrong r/w attributes set (at
least for a user to access the modem).

3. pppd is installed WITHOUT the SUID set.  While "usernet" works,
kppp tests for SUID being set and will not work if it is.

4. I got the current snapshot of gnome-network (gnome-ppp) to compile
and installed it.  This seems to work when gnome-ppp is SUID and
/dev/ttyS0 is set r/w but kppp still fails involving setting up the
modem??

5. rhl 6.0 seems to have changes enough stuff that kppp and gnome-ppp
have a hard time working properly -- except when run from a root login
(not just an su).

Gene
Comment 4 genec 1999-06-04 12:03:59 EDT
I "may" have found my problem with kppp and it "may" apply to others.
I have both gnome and kde installed (kde 1.1.1 final, not the stuff
being distributed but that should not make a difference).

The problem appears to be related to the modem being used (a 3com 56k
in my case).  The "default" for kppp appears to be to set the SOUND
VOLUME for the modem to low (0).  This appears to be the problem.  If
I increase the volume (e.g., to 1), it works OK.  I tried going back
and forth between the settings and for 0 (does not work) and for 1 (it
does work).

This looks more like a kde problem than an rhl problem.

Gene
Comment 5 Preston Brown 1999-06-08 12:08:59 EDT
We do not currently package kppp setuid root for security reasons.  It
has not been audited.

Setting the SUID bit on this file is an option left to users, and they
may do it at their own risk.

Note You need to log in before you can comment on or make changes to this bug.