Bug 259221 - anaconda has to handle compiz upgrades
Summary: anaconda has to handle compiz upgrades
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: compiz   
(Show other bugs)
Version: rawhide
Hardware: All
OS: All
medium
low
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-28 07:57 UTC by drago01
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-28 17:16:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description drago01 2007-08-28 07:57:08 UTC
Compiz in devel has been split into compiz, compiz-gnome and compiz-kde.
compiz itself is useless without one of them (no window decoration and no
desktop-effects app). 
A normal update will just update compiz but not pull in compiz-gnome, which
results into a broken setup. Compiz cannot require one of them because this
would make the split pointless.
So the only solution is that anaconda should handle this update.

Comment 1 Jeremy Katz 2007-08-28 14:44:37 UTC
No, compiz-gnome should obsolete compiz <= f7-compiz-version (and require compiz
= its version, which it already does).  Then depsolving should do the right
thing without requiring upgrade hacks.

Comment 2 drago01 2007-08-28 17:16:51 UTC
ok fixed in the compiz package.


Note You need to log in before you can comment on or make changes to this bug.