Bug 25936 - Installing with dns and all other items default doesn't work
Installing with dns and all other items default doesn't work
Status: CLOSED DUPLICATE of bug 25951
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-02-03 20:20 EST by sandy
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-02-04 00:31:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description sandy 2001-02-03 20:20:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Selecting dns(dhcp) and all other items defaults at install 
time results in a non-working network setup.  In the
/etc/resolv.conf the name servers are correct but the 
hostname and domain are incorrect (set to localhost localdomain)
All network scripts seem ok and the ether card module is
installed, networking comes up ok at boot time, but I can't 
access the network (www) or ping anyone.

Reproducible: Always
Steps to Reproduce:
1. install fisher 
2. choose dhcp network setup
3. select all other items defaults

Actual Results:  can not access network (www)

Expected Results:  should have access to network (www)

failed same way on two separate computers with different 
type hardware
Comment 1 sandy 2001-02-04 00:31:10 EST
I've diagnosed the problem.  The firewall is setup before the dhcp query for the
DNS nameservers.  Therefore /etc/sysconfig/ipchains does not have any 
permissions setup for the DNS namesevers.  Therefore the firewall prohibits 

(1) the host from resolving it's own DNS name from the nameservers

(2) the host from resolving any other DNS name from the nameservers.

I think you need to do the dhcp query before setting up the firewall permissions
during the boot.

To work around the problem I have to use the Text Mode Setup Utility "setup" 
to (1) remove the firewall configuration, (2) configure the network, (3)
the firewall again (I don't want to play with the init scripts).
Comment 2 Bill Nottingham 2001-02-05 19:54:06 EST

*** This bug has been marked as a duplicate of 25951 ***

Note You need to log in before you can comment on or make changes to this bug.