Bug 25954 - No way to install via NFS using multiple CD-ROM's
No way to install via NFS using multiple CD-ROM's
Status: CLOSED DUPLICATE of bug 12804
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-04 01:13 EST by Jaroslaw Sosnicki
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-06 12:50:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslaw Sosnicki 2001-02-04 01:13:21 EST
When I run into a CDROM disc changed problem, reported before, during my
BETA3 installation on my test system I was hoping that I will be able to
use NFS to mount distribution CD1 on /mnt/cdrom1 and CD2 on /mnt/cdrom2,
NFS export filesystems /mnt/cdrom1 and /mnt/cdrom2
on my production system and continue with installation.

But Nooooooo... 
You can't do that there is no option to handle distribution on multiple
CD's mounted 
somewhere else, and avoiding swapping the CD's.

I was also hoping that when I got missing file message I will be able to go
to my 
production system and unexport NFS exported directories, unmount /mnt/cdrom
that 
contained distribution CD1 and mount /mnt/cdrom containing distribution
CD2.

But Nooooooo...
You can't do that either, Installer generates message but does not releases
NFS file 
system for me to be able to remount CD and continue.

What I suggest are three options which could be incorporated into
installer:

1) to be able to specify multiple CD's that are needed during installation
to be NFS 
mounted at the same time on separate mounting points.

2) allow option to switch NFS mounted CD (if only one mounting point is
used) by 
releasing NFS mounting point and remounting it on the next try.

3) Option to go back and be able to fix the problem and restart install at
the point 
of failure when something goes wrong (At the moment the only option when
missing file 
message is displayed is to restart installation form scratch)

It would be a great improvement for the remote administration of the
servers when 
distributions CD's are NFS mounted on Jukebox and installer can be setup
for hands 
off installation.
Comment 1 Jeremy Katz 2001-02-04 01:43:23 EST
installer is anaconda and this is mostly a duplicate of a bug I filed back when
the dual cd install appeared in the 7.0 -- bug 12804, rfe to allow multiple dirs
for installing from.  Letting msf decide whether it's enough of a duplicate to
mark as such since it contains a couple of extra options.  2 and 3 aren't really
solutions as much as hacks though imho.
Comment 2 Michael Fulbright 2001-02-06 12:50:38 EST
If I understand this bug report correctly, it can be addressed by copying both
CDs into a single hierarchy. The shortcoming is it does require about 1.2 gig of
disk space on the NFS server, and we are aware of this issue. As mentioned
above, this is an RFE for future consideration.

*** This bug has been marked as a duplicate of 12804 ***

Note You need to log in before you can comment on or make changes to this bug.