Bug 2596 - Cron is confused by Y2K tests
Cron is confused by Y2K tests
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: crontabs (Show other bugs)
5.1
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
:
: 2597 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-06 09:03 EDT by innov8
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-10 17:59:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description innov8 1999-05-06 09:03:39 EDT
Upon changing the date to dec 31 1999 using date --set, and
waiting for the rollover to jan 1 2000 the crond ran it's
jobs as normal.  Using date --set again and setting the
date back to normal the crond would not run any of it's
jobs.  The log file for the crond reported nothing.
Killing and restarting the daemon left and error in the
crond stating that the PID was already in use.  None of the
crontab files in either /etc/crontab or /var/spool/user
were modified when the date was jan 1.  The problem was
resolved by rebooting the machine.
Comment 1 Jeff Johnson 1999-05-06 12:24:59 EDT
*** Bug 2597 has been marked as a duplicate of this bug. ***

Upon changing the date to dec 31 1999 using date --set, and
waiting for the rollover to jan 1 2000 the crond ran it's
jobs as normal.  Using date --set again and setting the
date back to normal the crond would not run any of it's
jobs.  The log file for the crond reported nothing.
Killing and restarting the daemon left and error in the
crond stating that the PID was already in use.  None of the
crontab files in either /etc/crontab or /var/spool/user
were modified when the date was jan 1.  The problem was
resolved by rebooting the machine.Time -- unlike clocks and computers -- is a monotonically
increqasing function. Crond is patiently waiting for the
computer to catch up.

Note You need to log in before you can comment on or make changes to this bug.