Bug 259601 - Missing man page for hgignore, missing examples, missing CGI, etc.
Missing man page for hgignore, missing examples, missing CGI, etc.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mercurial (Show other bugs)
7
All All
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-28 06:29 EDT by Jonathan S. Shapiro
Modified: 2008-05-14 10:39 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.9.5-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-14 10:39:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to setup.py to get contrib/ subtree installed (1.65 KB, text/x-patch)
2007-08-29 20:24 EDT, Jonathan S. Shapiro
no flags Details
Revised spec file incorporating missing installs and %files (2.97 KB, text/x-rpm-spec)
2007-08-29 20:24 EDT, Jonathan S. Shapiro
no flags Details

  None (edit)
Description Jonathan S. Shapiro 2007-08-28 06:29:47 EDT
Many things that are part of the release tarball are missing from the RPM
package. Some are important, including missing man page for hgignore, missing
hgweb.cgi/hgwebdir.cgi, and so forth.

I repeat my offer to assume packager or co-packager responsibility for this package.
Comment 1 Neal Becker 2007-08-28 06:39:09 EDT
 mercurial-0.9.4-1.fc7 is in updates-testing.  Would you like to send a patch 
to add anything missing?
Comment 2 Jonathan S. Shapiro 2007-08-28 13:57:47 EDT
Thank you, that is very generous. I may not be able to get a response to you
until late tomorrow or the next day -- we are in mid-releease here.
Comment 3 Jonathan S. Shapiro 2007-08-29 20:23:30 EDT
Neal: two attachments coming. The first is a patch to get the contrib/ directory
installed and tell the hgk extension where it went. This incidentally solves the
problem with missing hg-ssh and various cgi scripts. When you review, this is
the net effect of the setup.py patch. Choice of install location seems
consistent with FC convention, and also honors consensus from discussion on hg
IRC -- I'll be submitting both of these patches upstream, and I don't expect any
controversy.

The second is an updated spec file, because there were man an uninstalled man
page and a need to generate an /etc/mercurial/hgrc on the fly.

IMHO this is the least that should be done to build a clean RPM. These patches
do NOT resolve the issue that some widely used contrib packages are not yet
distributed as part of mercurial tarball (but soon will be). That update will be
very fast if you want it. Do you want me to pursue that as well?
Comment 4 Jonathan S. Shapiro 2007-08-29 20:24:27 EDT
Created attachment 180141 [details]
Patch to setup.py to get contrib/ subtree installed
Comment 5 Jonathan S. Shapiro 2007-08-29 20:24:58 EDT
Created attachment 180161 [details]
Revised spec file incorporating missing installs and %files
Comment 6 Neal Becker 2007-08-29 20:50:42 EDT
Nice!

I wonder if we should also install mercurial.el where emacs/xemacs will find 
it?
Comment 7 Jonathan S. Shapiro 2007-08-29 22:45:04 EDT
The HG team was extremely cooperative. I'm not a python hacker really, but with
their help the whole thing took < 4hrs once I got on it, including learning 
python distutils, which I had never looked at before. Hopefully their
involvement will help ease those patches into head upstream.

Concerning emacs: concern is that it may not be installed. At present, emacs
users can (load ..) it from the contrib dir.

Do you know if stuff be put in site-lisp before emacs core is installed? I
suspect the issue will come down to figuring out who actually owns the site-lisp
directory.

Oh, this is hugely funny. On my current FC6 machine, rpm -q -f
/usr/share/emacs/site-lisp names no fewer than five packages that claim to own
that directory. It's perfectly clear that some of those do not "Require:" emacs,
so I think we can do that safely.

Let me test whether that works first. If so, I assume you want the patch
appended here?
Comment 8 Jonathan S. Shapiro 2007-08-29 22:52:33 EDT
Neal: I have one further issue pending. It's a feature enhancement, and it may
turn out to be solved already, but I want to give you a "heads up".

From IRC discussions, hg currently uses the python sys.path to find extensions,
and it supposedly does not add any new locations to consult. If you want to
package an add-on extension, you either have to put it in site-lisp or tell
users to name its path explicitly. This presents some problems. If you put it in
site-lisp, then you'll get package collisions when an extension graduates into
core. If you have the user put in an explicit path, they'll forget they did it
and never see the later versions.

The hg team agrees this is an issue, that it is easy to fix, and three
approaches emerged. I'm exploring this now, and I'll either have it solved or
abandoned in a couple of hours. Because it impacts the ability to package
add-ons, you might want to hold -2 to incorporate this, or possibly spin -3.

Up to you; just providing a heads-up.
Comment 9 Neal Becker 2007-09-13 21:25:32 EDT
[ping Jonathan S. Shapiro] Any news on the above?
Comment 10 Bug Zapper 2008-05-14 10:07:53 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Jonathan S. Shapiro 2008-05-14 10:39:30 EDT
Since the immediate problem was resolved by later package updates, I'm closing this.

Note You need to log in before you can comment on or make changes to this bug.