Bug 25966 - [cardbus] PCMCIA network card on Panasonic CF47 notebook demands longer setup_delay
[cardbus] PCMCIA network card on Panasonic CF47 notebook demands longer setup...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Florence RC-1
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-04 03:37 EST by Peter H. Jones
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-14 01:13:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Complete dmesg log (6.98 KB, text/plain)
2001-02-04 03:43 EST, Peter H. Jones
no flags Details
lscpi-v output request (2.47 KB, text/plain)
2001-02-07 12:37 EST, Peter H. Jones
no flags Details
2nd copy of dmesg (6.30 KB, text/plain)
2001-02-07 12:39 EST, Peter H. Jones
no flags Details
First attempt to install latest kernel from Rawhide (3.34 KB, text/plain)
2001-03-13 11:38 EST, Peter H. Jones
no flags Details
dmesg log with Rawhide kernel 2.4.2-0.1.25 (5.49 KB, text/plain)
2001-03-13 14:30 EST, Peter H. Jones
no flags Details
Sample of dmesg log working with PCMCIA (6.43 KB, text/plain)
2001-03-14 01:01 EST, Peter H. Jones
no flags Details

  None (edit)
Description Peter H. Jones 2001-02-04 03:37:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (Win98; U)


Message: cs: socket c342d800 timed out during reset.  Try increasing setup_delay.

On a Panasonic CF47 laptop, a DELL FastEthernet 10/100 3Com BASE-TN card that had worked under RH 7.0 in the lower slot no longer 
works in either under RH Fisher Beta.
Furthermore, kudzu detected a TI PCI1251B. I didn't know I had one (or the equivalent) in my machine, for this message did not appear under 
RH 7.0.
I was pleased to see this card work with the installation disk + Additional PCMCIA, in the upper slot, where it also works under
the Windows 98 that came with the machine. 

Reproducible: Always
Steps to Reproduce:
1.Bootstrap RH beta, observe dmesg.
2.
3.
	

Actual Results:  Diagnostic message on screen, card does not work (green LED on adapter does not light).

Expected Results:  Should have initialized without error message.

dmesg output:
...
PCI: PCI BIOS revision 2.10 entry at 0xfd9de, last bus=0
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: Using IRQ router PIIX [8086/7110] at 00:07.0
PCI: Found IRQ 11 for device 00:0c.0
PCI: The same IRQ used for device 00:0e.0
PCI: Found IRQ 11 for device 00:0c.1
PCI: Cannot allocate resource region 0 of device 00:0c.1
  got res[10000000:10000fff] for resource 0 of Texas Instruments PCI1251B (#2)
Limiting direct PCI/PCI transfers.
.....
ACPI: System description tables found
    ACPI-0415: *** Warning: Reference \_SB_.LNKD AML 75F not found
    ACPI-0415: *** Warning: Reference \_SB_.LNKA AML 775 not found
    ACPI-0415: *** Warning: Reference \_SB_.LNKB AML 78B not found
    ACPI-0415: *** Warning: Reference \_SB_.LNKD AML 7A1 not found
    ACPI-0415: *** Warning: Reference \_SB_.LNKC AML 7B7 not found
    ACPI-0415: *** Warning: Reference \_SB_.LNKA AML 7CD not found
    ACPI-0415: *** Warning: Reference \_SB_.LNKB AML 7E3 not found
ACPI: System description tables loaded
ACPI: APM is already active, exiting
...
Linux PCMCIA Card Services 3.1.22
  options:  [pci] [cardbus] [pm]
Intel PCIC probe: 
  Intel i82365sl DF ISA-to-PCMCIA at port 0x3e0 ofs 0x00, 2 sockets
    host opts [0]: none
    host opts [1]: none
    ISA irqs (scanned) = 3,4,5,7,9,10 status change on irq 10
cs: socket c342d800 timed out during reset.  Try increasing setup_delay.
cs: IO port probe 0x0c00-0x0cff: clean.
cs: IO port probe 0x0800-0x08ff: clean.
cs: IO port probe 0x0100-0x04ff: excluding 0x220-0x22f 0x388-0x38f 0x398-0x39f 0x4d0-0x4d7
cs: IO port probe 0x0a00-0x0aff: clean.
cs: memory probe 0x0d0000-0x0dffff: excluding 0xd0000-0xdffff
cs: memory probe 0x0c0000-0x0cffff: excluding 0xc0000-0xcffff
...
Comment 1 Peter H. Jones 2001-02-04 03:43:21 EST
Created attachment 8899 [details]
Complete dmesg log
Comment 2 Sammy 2001-02-04 11:32:15 EST
I get the same problem with my 3c575 10/100 pcmcia card. As it is also
reported in the release notes of Fischer...2.4.x is not ready for pcmcia
stuff yet. I turned it completely off in the kernel, compiled pcmcia-cs
package and installled all the modules (if kernel has pcmcia on certain
modules in pcmcia-cs package that correspond to the kernel ones are not
compiled. So you need to compile kernel first without pcmcia and read
configuration from source tree when compiling pcmcia-cs package). After
this make sure that /etc/pcmcia/config file corresponds to the one that
does not use the kernel pcmcia e.g. your card should default to the driver
in the pcmcia-cs package (look at the config file in pcmcia-cs-1.3.24/etc
directory). Also /etc/sysconfig/pcmcia should have;

PCMCIA=yes
PCIC=i82365
PCIC_OPTS=
CORE_OPTS=
CARDMGR_OPTS=-f
Comment 3 Arjan van de Ven 2001-02-05 04:23:32 EST
Does "Additional PCMCIA" mean the pcmcia-cs package + the drivers in that
package ?
Comment 4 Glen Foster 2001-02-05 17:51:16 EST
We (Red Hat) should really try hard to fix this before next release.
Comment 5 Arjan van de Ven 2001-02-07 05:41:57 EST
Could you please attach the output "lspci -v" ?
Your dmesg suggests this might be an interaction with the PCI subsystem.
Comment 6 Peter H. Jones 2001-02-07 12:27:11 EST
Here is the lspci -v output, as requested. I've also attached another
dmesg output, from the same boot.
Comment 7 Peter H. Jones 2001-02-07 12:32:09 EST
2nd try to upload attachments promised.
Comment 8 Peter H. Jones 2001-02-07 12:34:56 EST
still can't find a button to upload
Comment 9 Peter H. Jones 2001-02-07 12:37:19 EST
Created attachment 9259 [details]
lscpi-v output request
Comment 10 Peter H. Jones 2001-02-07 12:39:47 EST
Created attachment 9260 [details]
2nd copy of dmesg
Comment 11 Arjan van de Ven 2001-03-12 14:21:25 EST
Please try the most recent rawhide kernel, this contains a critical bugfix
for cardbus.
Comment 12 Peter H. Jones 2001-03-13 11:35:02 EST
I tried to install the newest kernel from Rawhide, but am running into 
dependency problems I would have liked to know about ahead of time. As the 
ethernet card is not working, I am using Windows98 to transfer the required 
files to hard disk.
The kernel depends on modutils and kudzu. modutils installs as an upgrade, but 
kudzu needs pam, Xconfigurator and mouseconfig.
I plan to obtain these from Rawhide, and post results later.
Attachment sess1.txt, an abbreviated script output file, shows my results so 
far.
Comment 13 Peter H. Jones 2001-03-13 11:38:12 EST
Created attachment 12582 [details]
First attempt to install latest kernel from Rawhide
Comment 14 Arjan van de Ven 2001-03-13 11:40:17 EST
You should be able to install the kernel with --nodeps
Comment 15 Peter H. Jones 2001-03-13 14:30:25 EST
Created attachment 12623 [details]
dmesg log with Rawhide kernel 2.4.2-0.1.25
Comment 16 Peter H. Jones 2001-03-13 14:33:58 EST
I have updated the kernel from Rawhide. I powered down, then started my
machine with the PCMCIA in the upper slot. Significant dmesg output is in
dmesg_top_power_13.txt; highlights are shown below.

The "timed out" message appears when I insert the card, with an address
depending which slot I try. 

----- Abbreviated dmesg output:
Linux version 2.4.2-0.1.25 (root@porky.devel.redhat.com) (gcc version 2.96 
20000731 (Red Hat Linux 7.1 2.96-78)) #1 Fri Mar 9 20:45:41 EST 2001
...
Kernel command line: auto BOOT_IMAGE=linux ro root=303 
BOOT_FILE=/boot/vmlinuz-2.4.2-0.1.25
...
PCI: PCI BIOS revision 2.10 entry at 0xfd9de, last bus=0
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: Using IRQ router PIIX [8086/7110] at 00:07.0
PCI: Found IRQ 11 for device 00:0c.0
PCI: The same IRQ used for device 00:0e.0
PCI: Found IRQ 11 for device 00:0c.1
PCI: Cannot allocate resource region 0 of device 00:0c.1
  got res[10000000:10000fff] for resource 0 of Texas Instruments PCI1251B (#2)
Limiting direct PCI/PCI transfers.
...
PCI: Found IRQ 11 for device 00:07.2
PCI: The same IRQ used for device 00:0a.0
usb-uhci.c: USB UHCI at I/O 0xfca0, IRQ 11
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
usb.c: registered new driver iforce
...
ip_conntrack (511 buckets, 4088 max)
Linux PCMCIA Card Services 3.1.22
  options:  [pci] [cardbus] [pm]
Intel PCIC probe: 
  Intel i82365sl DF ISA-to-PCMCIA at port 0x3e0 ofs 0x00, 2 sockets
    host opts [0]: none
    host opts [1]: none
    ISA irqs (scanned) = 3,4,5,7,9,10 status change on irq 10
cs: socket c32fa000 timed out during reset.  Try increasing setup_delay.
cs: IO port probe 0x0c00-0x0cff: clean.
cs: IO port probe 0x0800-0x08ff: clean.
cs: IO port probe 0x0100-0x04ff: excluding 0x220-0x22f 0x378-0x37f 0x388-0x38f 
0x398-0x39f 0x4d0-0x4d7
cs: IO port probe 0x0a00-0x0aff: clean.
cs: memory probe 0x0d0000-0x0dffff: excluding 0xd0000-0xdffff
cs: memory probe 0x0c0000-0x0cffff: excluding 0xc0000-0xcffff
--- End of abbreviated dmesg output
Comment 17 Arjan van de Ven 2001-03-13 14:48:25 EST
Ehm. Does "lsmod" show that yenta_socket is loaded, or does it show i82365 ?
Comment 18 Peter H. Jones 2001-03-14 01:01:52 EST
Created attachment 12643 [details]
Sample of dmesg log working with PCMCIA
Comment 19 Peter H. Jones 2001-03-14 01:13:24 EST
I think I've resolved the bug. I updated with the following rpm's from Rawhide:

kernel-2.4.2-0.1.25.i686.rpm
kernel-pcmcia-cs-3.1.24-1.i386.rpm
kudzu-0.97.6-1.i386.rpm
modutils-2.4.2-5.i386.rpm
mouseconfig-4.18-1.i386.rpm
pam-0.74-17.i386.rpm

because they were mentioned when I first tried to install the updated kernel. In 
general, I used "rpm -iUv --nodeps". I don't know if all the above rpm's are in 
fact necessary.

Now, the system boots, and the card works in the upper slot; I was able to run a 
 brief ncftp session.

For illustration, attached file dmesg_ok.txt shows the dmesg log I have. Below 
is the diff from dmesg_top_power_13.txt, the previous attempt.
--- cut here ---
*** dmesg_top_power_13	Tue Mar 13 13:34:57 2001
--- dmesg_ok	Wed Mar 14 00:16:22 2001
***************
*** 14,18 ****
  Kernel command line: auto BOOT_IMAGE=linux ro root=303 
BOOT_FILE=/boot/vmlinuz-2.4.2-0.1.25
  Initializing CPU#0
! Detected 364.746 MHz processor.
  Console: colour VGA+ 80x25
  Calibrating delay loop... 727.44 BogoMIPS
--- 14,18 ----
  Kernel command line: auto BOOT_IMAGE=linux ro root=303 
BOOT_FILE=/boot/vmlinuz-2.4.2-0.1.25
  Initializing CPU#0
! Detected 364.740 MHz processor.
  Console: colour VGA+ 80x25
  Calibrating delay loop... 727.44 BogoMIPS
***************
*** 103,119 ****
  hub.c: 2 ports detected
  usb.c: registered new driver iforce
  ip_conntrack (511 buckets, 4088 max)
  Linux PCMCIA Card Services 3.1.22
    options:  [pci] [cardbus] [pm]
! Intel PCIC probe: 
!   Intel i82365sl DF ISA-to-PCMCIA at port 0x3e0 ofs 0x00, 2 sockets
!     host opts [0]: none
!     host opts [1]: none
!     ISA irqs (scanned) = 3,4,5,7,9,10 status change on irq 10
! cs: socket c32fa000 timed out during reset.  Try increasing setup_delay.
  cs: IO port probe 0x0c00-0x0cff: clean.
- cs: IO port probe 0x0800-0x08ff: clean.
  cs: IO port probe 0x0100-0x04ff: excluding 0x220-0x22f 0x378-0x37f 0x388-0x38f 
0x398-0x39f 0x4d0-0x4d7
  cs: IO port probe 0x0a00-0x0aff: clean.
! cs: memory probe 0x0d0000-0x0dffff: excluding 0xd0000-0xdffff
! cs: memory probe 0x0c0000-0x0cffff: excluding 0xc0000-0xcffff
--- 103,139 ----
  hub.c: 2 ports detected
  usb.c: registered new driver iforce
+ Winbond Super-IO detection, now testing ports 3F0,370,250,4E,2E ...
+ SMSC Super-IO detection, now testing Ports 2F0, 370 ...
+ parport0: PC-style at 0x378 [PCSPP,TRISTATE]
+ parport0: cpp_daisy: aa5500ff(38)
+ parport0: assign_addrs: aa5500ff(38)
+ parport0: cpp_daisy: aa5500ff(38)
+ parport0: assign_addrs: aa5500ff(38)
  ip_conntrack (511 buckets, 4088 max)
  Linux PCMCIA Card Services 3.1.22
    options:  [pci] [cardbus] [pm]
! PCI: Found IRQ 11 for device 00:0c.0
! PCI: The same IRQ used for device 00:0e.0
! PCI: Found IRQ 11 for device 00:0c.1
! Yenta IRQ list 06b8, PCI irq11
! Socket status: 30000006
! Yenta IRQ list 06b8, PCI irq11
! Socket status: 30000020
! cs: cb_alloc(bus 5): vendor 0x10b7, device 0x5057
!   got res[1c00:1c3f] for resource 0 of PCI device 10b7:5057
!   got res[10c00000:10c0ffff] for resource 6 of PCI device 10b7:5057
! PCI: Enabling device 05:00.0 (0000 -> 0003)
  cs: IO port probe 0x0c00-0x0cff: clean.
  cs: IO port probe 0x0100-0x04ff: excluding 0x220-0x22f 0x378-0x37f 0x388-0x38f 
0x398-0x39f 0x4d0-0x4d7
  cs: IO port probe 0x0a00-0x0aff: clean.
! 3c59x.c:LK1.1.13 27 Jan 2001  Donald Becker and others. 
http://www.scyld.com/network/vortex.html
! See Documentation/networking/vortex.txt
! eth0: 3Com PCI 3c575 Boomerang CardBus at 0x1c00, PCI: Setting latency timer 
of device 05:00.0 to 64
!  00:60:08:d1:e6:6e, IRQ 11
!   product code 4b59 rev 06.0 date 04-09-98
!   8K word-wide RAM 3:5 Rx:Tx split, autoselect/MII interface.
!   MII transceiver found at address 0, status 7809.
!   Enabling bus-master transmits and whole-frame receives.
! eth0: scatter/gather disabled. h/w checksums disabled
! eth0: first available media type: MII
! eth0: first available media type: MII
--- cut here ---

I'm willing to consider the bug resolved, but I'll let RedHat staff do that, 
possibly after a review. Thanks, RedHat for the help.
Comment 20 Arjan van de Ven 2001-03-14 04:04:15 EST
I think I know that the problem was. The old version of your pcmcia init scripts
tried to load the i82365.o module, which used to be for all PCMCIA slots. But
with 2.4 kernels i82365.o is only for "old style" (ISA-bus like) PCMCIA slots.
Your laptop has "new style" cardbus slots (which are PCI-bus like) and the 2.4
kernel uses the module "yenta_socket" for that. 

Older pcmcia-cs RPMS apparently didn't upgrade this for you (I've had one more
of such report but that was a totally different laptop) but newer ones do.

Thank you for helping us test; I'll close this bug as "fixed" now.

Note You need to log in before you can comment on or make changes to this bug.